Google Answers Logo
View Question
Q: BIOS refuses to boot bootable CD ROMS ( Answered 5 out of 5 stars,   4 Comments )
Subject: BIOS refuses to boot bootable CD ROMS
Category: Computers > Hardware
Asked by: ianc-ga
List Price: $10.00
Posted: 21 Nov 2002 18:30 PST
Expires: 21 Dec 2002 18:30 PST
Question ID: 112296
Although my BIOS supports bootable CD-ROMS, when I select the
following boot device order, the CD-ROM never boots (despite original
bootable CDs being loaded in the drive).  1) Floppy, 2) CD-ROM, 3)

Motherboard: Gigabyte 7ZXR (BIOS software v.9)
CD ROM: Plextor 16/10/40A IDE (connected to IDE port 3)

Request for Question Clarification by seizer-ga on 21 Nov 2002 19:43 PST
Does your motherboard support RAID? I assume so, if the CD is
connected to IDE3. Have you tried it on IDE 0/1?
Subject: Re: BIOS refuses to boot bootable CD ROMS
Answered By: haversian-ga on 22 Nov 2002 01:29 PST
Rated:5 out of 5 stars
Hello ianc,

Troubleshooting is rarely a one-shot proposition so this answer will
not necessarily solve your problem.  I will ask you to try several
things and (if none work) report the results.  I will then suggest
that you try new things based on the results of the first round. 
Don't be discouraged if a solution is not immediately forthcoming;
post a clarification request with your findings and I will be

First off, are you absolutely sure the CD is bootable?  Have you
successfully booted it in another computer?  Are you sure the CDROM is
OK?  Can you read the CD you are trying to boot off of in the CDROM
drive you are trying to boot it from, with the OS booted from the hard
drive?  Plextor is a good company so I suspect the drive is fine, but
it always pays to be paranoid about these things.

Does your BIOS recognize the CDROM drive?  My BIOS gives a listing
something along the lines of:

Pri. master    ATA/100   LBA . . . . .
Pri. slave     ATA/100   LBA/48  . . .
Sec. master    ATAPI     CDROM . . . .

Your OS may recognize the CDROM even if your BIOS doesn't.  This works
fine once the OS is booted, but if you expect the BIOS to use the
drive, it has to be copasetic.

Is the boot sequence and/or error messages different if there is a CD
in the CDROM drive versus when there is no CD in and you still try to
boot from CD?

You mention BIOS version 9 - is this the default your motherboard
shipped with?  Also, what motherboard revision do you have?  Gigabyte
notes that there are 3 revisions of this board.  I don't see in the
manual where the PCB revision would be noted on your motherboard, but
I would recommend looking at the top right corner first.

That should be enough to get you started.  Check back frequently - I
check for clarification requests twice or more a day so we should be
able to get this worked out fairly quickly.


Request for Answer Clarification by ianc-ga on 25 Nov 2002 16:31 PST
Hello Haversian

Here are the answers to your questions:

Yes, I am sure the CDs I'm trying to boot from are bootable CDs.  I've
tried them in an alternate computer and they boot up as they should. 
Indeed, once the computer is booted (from hard disk), I can read the
CD-ROM without any problem whatsoever.

At startup, the BIOS does indeed correctly detect and identify the
CD-ROM drive.

The boot sequence and messages displayed are identical whether a CD is
within the drive or not.

No, BIOS version 9 is the latest version I've downloaded from
Gigabyte's website.  It came with version 4 - and have also tried
booting with this version (by booting off the backup BIOS).

My board is revision 3.0

Look forward to hearing any further suggestions.


Clarification of Answer by haversian-ga on 26 Nov 2002 08:08 PST
Hello Ianc,

Ok, it sounds like the CD is fine and the CDROM drive is fine.  Do you
know if this computer has *ever* successfully booted from a CD?

The specifications claim that IDE1-4 should be able to boot to CD. 
Could you please unplug all IDE devices except the CD, and plug that
into the primary IDE chain?  While you are at it, please check the
jumpers on your CDROM drive.  Many IDE devices have separate jumper
settings for master and single-drive settings.  In many cases there
are 3 jumpers, one each for master, slave, and cable select - no
jumpers at all correspond to single-drive operation.

> The boot sequence and messages displayed are identical whether a CD
within the drive or not.
     That may indicate that the BIOS does not recognize the CDROM
drive as something it should boot from.  Could you check your BIOS
again?  I'm sure you have set your computer properly to boot from CD
before IDE, but some BIOSes have more settings than that.  Mine for
example has an ATA100/SCSI option and a CD/NETWORK option.  There are
settings on a different page somewhere that control whether
ATA100/SCSI means ATA or SCSI, and the same for the CD/NETWORK option.
 So while you may have selected CDROM as the first boot device, other
settings might be changing what seems to be a straightforward option.
> My board is revision 3.0
     That's good - you got the newest one.  While I wait for your
responses, I will look through the manual for that board version.


Request for Answer Clarification by ianc-ga on 26 Nov 2002 15:19 PST
Hello Haversian

Ok, some progress made this evening.  I disconnected everything like
you suggested, except for the CD-ROM (already set to Master) on the
Primary IDE port, checked the BIOS settings, and made sure the IDE
ports were set to "auto".  Success - the CD-ROM booted.

So, I then thought what can I connect to make it not work.  I added
the tape drive to the Primary slave port and ah-ha... it didn't boot
from the CD-ROM.  Then, I swapped both the CD-ROM and tape drive's
master/slave relationship and it still didn't work.  Finally, I
performed an IDE device auto-detection from within the BIOS and found
that this then allowed the system to boot from the CD-ROM.  Connected
everything back, re-performed the BIOS IDE automatic device detection
and everything worked.

However, the odd thing is that if I set the BIOS to do an auto-detect
upon power-up, it doesn't work.  Get the BIOS to do the detection once
whilst within the BIOS setup screens, and everything works.

Very odd.

So, many thanks for your help!  Any idea as to why this abnormality is
occuring?  Naturally, I'd prefer auto-detection upon power-up, but if
without this I can boot from the CD, then I know what I'd prefer!


Clarification of Answer by haversian-ga on 26 Nov 2002 21:53 PST
> Any idea as to why this abnormality is occuring?

Yes I do.  In order to boot from CD, the BIOS needs to know that you
have a CDROM installed, and where it is to be found.  However, if the
system has *no* drives detected because autodetection is set for
later, it can't boot.  Hard drives require a much older and more
primitive system in order to boot, so they're pretty fool-proof.  It
basically comes down to poor BIOS programming - there is no reason why
the system cannot autodetect drives, then search for CDROM devices,
and then decide which to boot from.

I'm glad we got everything working for you.  If you are interested,
you might experiment a little more and then submit a bug report to
Gigabyte with your findings.  It's a thrill when a later version comes
out and they've fixed something you suggested.

ianc-ga rated this answer:5 out of 5 stars
Very helpful, and the real belief that they are interested in the
issue at hand and want to solve it.

Subject: Re: BIOS refuses to boot bootable CD ROMS
From: tisme-ga on 21 Nov 2002 19:43 PST

Is there a floppy disk inserted into the computer? This would cause
the computer to boot from the floppy and not the CD-ROM.

What operating system are you using? It could be that your CD-ROM is
not generic and that it is not recognized when it is starting up. Does
your CD-ROM drive work after you insert a DOS boot disk?

Subject: Re: BIOS refuses to boot bootable CD ROMS
From: funkywizard-ga on 21 Nov 2002 23:39 PST
I have found that a large number of computers require that you hit
"any key" at some specific time during bootup to activate the booting
of a cdrom. Has this been considered? Perhaps the message is obscured
by some fancy "splash screen" that is designed to protect the average
user from seeing all that black and white text that comes by as the
computer starts up. If so, this can usually be disabled in the bios.
Subject: Re: BIOS refuses to boot bootable CD ROMS
From: ianc-ga on 22 Nov 2002 00:55 PST
Sorry, my mistake.  Yes, it does support RAID, but the CD-ROM is
actually on IDE 1 (I expressed IDE "3" originally since it's the third
device, ie, Secondary Master).

With a floppy in the dirve, it does boot to floppy.  I'm running
Windows XP, but the problem existed whilst Windows 2000 was installed.
 The problem is most evident when installing Windows XP, for example,
where I was hoping to bung the CD in the drive and off we go!  I'm 
also in the need to boot into Linux (via a Linux boot CD) for the
upgrading of a TiVo Personal Video Recorder.   Neither boot.

Finally, another machine I have does prompt me to press any key in
order to boot from the CD-ROM, so I was aware that this is a
possibility.  No message is displayed, but I've tried pressing keys
during the power-up cycle without any success.  If I remove the third
boot option (ie, ATA-100) and leave just a) floppy and b) CD-ROM, it
eventually times out with the error "Error loading OS" - exactly the
message when this particular BIOS can't find any boot records.
Subject: Re: BIOS refuses to boot bootable CD ROMS
From: ianc-ga on 22 Nov 2002 00:58 PST
So just for clarity, this is how things are connected inside the PC:

Primary Master: NTFS partitioned hard disk
Primary Slave: NTFS partitioned hard disk
Secondary Master: CD-ROM drive
Secondary Slave: Tape backup
ATA-100 Device 0: NTFS partitioned hard disk - my primary boot disk
ATA-100 Devices 1-3: No connection

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy