Google Answers Logo
View Question
Q: Computers ( Answered 5 out of 5 stars,   0 Comments )
Subject: Computers
Category: Computers > Operating Systems
Asked by: osmosis_vic-ga
List Price: $10.00
Posted: 18 Feb 2003 02:31 PST
Expires: 20 Mar 2003 02:31 PST
Question ID: 162902
I have accidentally edited the association for 'File Folder' under
view>file types.  This has caused my windows explorer to no longer let
me browse directories in the right pane of the explorer window.  I've
added 'explore' to the file association as an action, and assigned it
to use 'explorer.exe', but this has the drawback of opening a new
explorer each directory I explore.  I am unable to remove 'explore'
from the association now, and cannot restore that association to
default.  How do I restore the file association for "File Folder"?
Subject: Re: Computers
Answered By: arcadesdude-ga on 18 Feb 2003 09:08 PST
Rated:5 out of 5 stars
Hello Osmosis_vic!

File associations can really mess things up if they are incorrect. To
see how to fix your problem I changed the file association for
directories (File Folder) myself and then repaired it to make sure
this works. It's not too hard to fix, (but you can always ask for more
help by "Requesting Answer Clarification" if you need it).

File Associations in Windows are stored in the registry. These are a
couple files (usually 2 or 3) in the Windows system folder that store
many settings used by the operating system (Windows) and other
programs. You can change settings by using RegEdit or by using the
Start, Settings, Folder Options, View dialog. Now we'll fix the folder

Download this registry file here:

File Folder Registry Fix

Note that the file will be available for 30 days (from Feb. 18 to
March 20) then it won't be there anymore.

When you download it you might have to right-click on it and then
choose (Save File As... or Save As...) then save it to the desktop.

On the desktop click on that file (or double click on it if a single
click just turn it blue (highlights it)). Once you have done that then
a box should pop up that says: "Are you sure you want to add the
information in C:\WINDOWS\Desktop\FileFolder.reg to the registry?"
Click YES. This will add the information that is in the file (it is
plain text so you can open it in any text editor and see that it
restores the directory file folder to the default). It should say
Information was successfully entered into the registry.

If you did not get the "Are you sure..." prompt to come up when you
double (or single) clicked that reg file then please "Request Answer
Clarification so I can explain how to manually edit the registry to
put that information in. That is unlikely to happen, however, unless
the .reg file association is also messed up. Hopefully, it will work
as normal so it will be much easier to fix this.

Now that we added the information to the registry, when you click on a
folder it should act as normal because it is set to open in Explorer
(using the  "/idlist,%I,%L" option so it acts like a normal directory
without the left hand explorer pane like it should). Also the option:


means that the default action taken when a directory is clicked is
"Open" (because "" means nothing different is chosen then open will be
used) and open has been reset to Explorer (to open the window with the
files in it).

The reg file imported the default file association for folders and
overwrote the messed up version that you had. In other words it the
file association that was messed up (File Folder) should now be

In your question you mention that it opens a new explorer each time
you open a folder. This might be fixed by the above but there is a
setting in Windows which allows you to change this behavior if you

Click Start
Click Settings
Click Folder Options
Click Custom
Click Settings (to the right of where you just clicked Custom)
In the Browse Folders as follows Click: Open each folder in the same
Click OK
Click Close

Open each folder in the same window means it won't open a new Explorer
window for every directory you click. (Unless you want that then you
can change the setting to Open each folder in its own window). That
should make folders stay in the window you're currently in (like when
you browse most webpages in your browser they normally don't open a
new window (unless that link you click on automatically tells it to
but you don't normally have control over browsing webpages in that

Now you might have to restart for changes to take affect. (Start, Shut
Down, then click Restart, then OK). When you click on directories now
they should not open another window each time you look through the

The above should fix your File Folder (Directory) associations. If it
does not work as intended then please "Request Answer Clarification"
before you "Rate this Answer" and I'll be happy to help you further.

Google Answers Researcher

Further Reading:

Registry Guide for Windows

Annoyances (and possible fixes) for Windows

Manage File Associations (Definition),4149,589698,00.asp

Introduction to File Associations

File Extensions, Registered Viewers, Changing File Associations

TechTV | Open With... What? The History of File Associations (Mac),23102,2570002,00.html

Search Strategy:

registry windows

file associations

Request for Answer Clarification by osmosis_vic-ga on 18 Feb 2003 13:01 PST
Hi arcadesdude-ga,

I've added the registry information into my registry as instructed,
but there was no visible change in the behavior of my explorer. 
Missing information that I realize I should have provided is that I am
using windowsXP.  I suspect your fix is for a different version, as
your fix for the new explorer window follows a path that I do not
have.  However, I know the setting location in windows XP . There are
2, one at the file types dialog (when I hilight File Folder and select
'advanced', there is a radio button which says 'Browse in same
window', which I cannot select.  I should also point out here that I
cannot remove any of the actions associated here)  and another within
folder options>view 'Launch folder window in a seperate process'
(which is unchecked).

I've posted a few pictures to demonstrate my problems.  

The first is where the problem lay (I believe), .

The second is pre-browsing using explorer, and the third is post
browsing the same directory.  and

The most confusing part about this problem is that the problems began
when I changed the folder ICON for 'File Folder'.  I have returned the
icon to the original icon (which was located in shell32.dll) but it
has not returned to proper function.

Thank you for the assistance thus far, please let me know if you need
further clarification.

Clarification of Answer by arcadesdude-ga on 18 Feb 2003 13:47 PST
Windows XP must have a different registry path for this setting. I see
the grayed out part there that won't let you change the browse in same
window (which should be the function we want to change).

I see what might be the problem. I'm pretty sure the registry path is
correct but there are two entries for File Folder in my registry. One
in the root and one in HKLM\Software\CLASSES which is the correct one
to change. This path is different than the other path and may be what
Window requires. If it does not however then please open regedit and
search for File Folder in the registry so we can manually find the
path and update to the correct settings.

Try this reg file: 

If that does work then I am sorry I did not realize the first was not
the correct path and you won't have to do any of the other suggestions
below. But if it does not then do this:

Click Start
Click Run
Type Regedit
Click OK (or hit Enter)

Click Edit
Click Find
Check all the check boxes (to search entire registry and whole word
Type "File Folder"  (without the quotes) into the find field
Click Find Next

When it has found File Folder then make sure it's not the one we added
in the root directory (which was HKEY_CLASSES_ROOT\Directory) or the
one we just added in HKEY_LOCAL_MACHINE\Software\CLASSES\Directory. If
it is found and is neither of these directories then WinXP uses a
different directory and must be changed manually like this:

should be "" (nothing but an empty string).

If it works after this then you're done, if not read on.

If after you have changed that and it does not work then it might be
that the File Folder association is corrupted and treated like a
normal file (might explain why browse in same window is grayed out).
If this is the case you can use TweakUI to Repair File Associations
(only the default ones but if you've changed them any changed will be

TweakUI can be downloaded here:

WinXP TweakUI Instructions:

Once you run TweakUI there is a Repair tab which will have File
Associations that you can repair which might fix this problem.

Request for Answer Clarification by osmosis_vic-ga on 18 Feb 2003 17:51 PST
Hi arcadesdude-ga,

When I do a search for "File Folder", I am directed to
HKEY_CLASSES_ROOT\directory and further to
HKEY_LOCAL_MACHINE\SOFTWARE\classes\Directory, so verified that the
reg files you've provided are indeed installing into those locations.

I've added a screenshot of the registry value for
HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell here : , and I've gone ahead
and deleted the 'explore' value that I had previously added there,
which has reverted the folder browsing action from opening an explorer
window to opening the search window (for the 'find' action, which was
there already before this problem began.

When you say "HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell 
should be "" (nothing but an empty string). " do you mean for me to
delete the Default key (in the screenshot)?

Also, I have downloaded and installed TweakUI, but there is no option
to repair file associations.

Clarification of Answer by arcadesdude-ga on 19 Feb 2003 10:45 PST
I would have thought TweakUI had an option to repair the file
associations like here:

TweakUI screenshot

It might not have that on the XP version, however.

You shouldn't delete the default key. It appears to be correct (no
data but the key exists as it should). That is how it should be.
Perhaps the association for "Folder" (not "Directory") is actually
what is used for opening folders.

Look in here:

If in there in:
the default is set up to be find files (search)
then change default (by right clicking on default on the right side
and choosing modify) to nothing in the box then click OK.

Now click the plus sign next to shell (expand that key) and you should
have explore and open. (If you don't have one or both then add them
with this file: ) Check that the
command for explore is:
C:\WINDOWS\Explorer.exe /e,/idlist,%I,%L
and the command for open is:
C:\WINDOWS\Explorer.exe /idlist,%I,%L

You can also try putting "Explorer.exe /idlist,%I,%L" (with no quotes)
instead of just explore in the Folder Options, File Types menu for
File Folder by editing File Folder and adding that explore command.
Also in here check the file type "Folder" and make sure it is set to
open as the default command (instead of find/search).

If after all that it still doesn't work, I could ask the editors to
remove my answer so that you won't be charged for any work I've done
and so that another research can help you. I would like to help
further if I can but I might not be able to. That would allow someone
else to help if any of the above suggestions do not alleviate your
problem. But if the above does help, then I will be glad we fixed this
problem. Let me know how it goes so we can decide what to do from

Request for Answer Clarification by osmosis_vic-ga on 19 Feb 2003 12:04 PST
Hi Acradesdude-ga,

I believe that the problem indeed lay in the registry area of
HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell, this is where the
problem began as I attempted to change the icon for 'File Folder'.

After a bit of wiggling, I have solved the problem.  While not
providing the exact answer, you certainly led me to it so I am more
than satisfied with your answers.  What I have done is to export the
'explore' registry value listed under 
HKEY_LOCAL_MACHINE\Software\CLASSES\Folder and modified the values
contained in the .reg file to install the 'explore' folder into
HKEY_LOCAL_MACHINE\Software\CLASSES\Directory\shell.   This has worked
perfectly, and I wouldnt have been able to discover this by myself.

Thanks for all your solutions! :)

Clarification of Answer by arcadesdude-ga on 19 Feb 2003 15:44 PST
I'm not actually providing a clairification; I'm just clearing the
needs clairification flag on this question so it doesn't show 'needs
clairification' every time I check my answers.

Osmosis_vic, that's great! I'm sure it was a registry problem but I
couldn't seem to hit the nail on the head (idiom meaning I couldn't
seem to get the problem's solution exactly). I'm glad you got it to
work because I was out of ideas at that point. Thank you for the 5
stars and the tip!
osmosis_vic-ga rated this answer:5 out of 5 stars and gave an additional tip of: $5.00

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy