Google Answers Logo
View Question
Q: dll Error ( Answered 4 out of 5 stars,   0 Comments )
Subject: dll Error
Category: Miscellaneous
Asked by: fabios_ss-ga
List Price: $10.00
Posted: 27 Feb 2003 20:38 PST
Expires: 29 Mar 2003 20:38 PST
Question ID: 168171
I am getting an error whilst installing a aplication on a NT Server.
(Sp 6a)

"The procedure entry point__lc_collate_cp could not be located in the
dynamic link library MSVCRT.dll"

I have reaplied the service pack but no avail.

Any suggestions!
Subject: Re: dll Error
Answered By: arcadesdude-ga on 27 Feb 2003 22:01 PST
Rated:4 out of 5 stars

I think the problem lies in one file, MSVCRT.dll and it's version (how
new it is). First I'll suggest some possible problems and then I will
walk you through step by step as if you have all of them. This way we
can troubleshoot multiple causes at the same time and hopefully fix
the problem for good.

The problem seems to be with the file MSVCRT.dll. Though the software
seemed to install properly, that one file may have been in use and
this might cause the problem. A couple other reasons could be the
program not recognizing the correct version, overwriting a newer
version of MSVCRT.dll during the install, or another program using a
newer version when the program specifically needs and older one. Also,
it could be caused by multiple or incorrectly installed Microsoft's
Visual C Runtime Libraries.

Subject: Re: Extensions Manager error, Message 7 in thread

The other problem could be as simple as a reboot:

Missing dll MSVCRT after installing ADAMS.


(This is meant to cover the most common causes of this problem but
might not catch your particular problem. If it does not work then
please "Request Answer Clarification" and explain what's happening and
what steps you followed and I'll help you until a satisfactory
solution is found).

First step is to get the easy possible problems out of the way.

Reboot the computer. (Start, Shut Down, Restart, OK)

Test the problem again (try to see if you can make the error reoccur
by thoroughly running the application again). If the error message
does not occur then the problem is probably fixed.

I doubt this is the problem, however, and think the next method would
work better.

Download MSVCRT.dll (6.10.8637.0) from here:

and place it on the desktop (or where you can easily access and
remember it when we use it later).

Now we'll need to restart the computer again, but this time in safe

How to boot WinNT into safe mode.

Then restart the computer and choose:
SAFE Windows NT Workstation Version 4.00 (or whatever version you
choose to call it).

This will use the base vga driver (so you'll probably get 640*480*16
resolution which means everything might look less colorful and "zoomed
in") and skip your startup files.

Now find MSVCRT.dll (Start, Find, File or Folders, Named MSVCRT.dll,
Find Now).
You might have multiple copies. The one(s) you are interested in are
the one in the system folder:
c:\winnt\system32 (and possibly the one in the folder of the program
that is giving the error IF there is one there as well, if not then
the system folder one is the only one we're concerned with).

Right-click on MSVCRT.dll and Rename it to MSVCRT.old -- that's so you
can undo the change if it needs to be done later.

Now try reinstalling the program that gives the error message. The
installer program should be able to correctly copy over MSVCRT.dll now
(because it's not in use).

Now Reboot (into regular mode) and Test it again. If it works then it
is probably fixed. If it does not then reboot into safe mode again and
delete MSVCRT.dll from the place(s) you renamed it earlier. Now copy
over the file that you downloaded to the desktop (or wherever) and put
it in the system folder (and in the program's folder if you found a
version in there before).

Now reboot into regular mode and test again. Hopefully, this solves
the problem, if not read on.

From this post here:

Subject: Re: CheckPoint - Msvcrt.dll error, Message 2 in thread

it could also be a problem with MFC42.DLL. If this is the case try the
above steps with both MSVCRT.dll and MFC42.dll. What I mean by that
is, rename and replace both files at the same time in the above steps
(wherever this is msvcrt.dll also do the same with mfc42.dll).

A copy of MFC42.dll can be found here:

I hope this fixes the problem, but if it doesn't, or if anything is
unclear, then please "Request Answer Clarification" before you "Rate
this Answer" and explain what's happening and I'll do my best to help
solve this for you.

Google Answers Researcher


MSVCRT.dll download

MFC42.dll download

Missing dll MSVCRT after installing ADAMS.

Subject: Re: Extensions Manager error, Message 7 in thread

How to boot WinNT into safe mode.

Subject: Re: CheckPoint - Msvcrt.dll error, Message 2 in thread

Search Strategy:

"The procedure entry point__lc_collate_cp could not be located in the
dynamic link library MSVCRT.dll"


"The procedure entry point__lc_collate_cp could not be located in the
dynamic link library MSVCRT.dll"
fabios_ss-ga rated this answer:4 out of 5 stars
Thanks for your help!
I had one issue.

That was when I logged into safe mode I went to rename the msvcrt.dll
but windows would not let me as it said that the file was being used
by windows. So I sneakily went into dos and successfully renamed the
file that way.
I then went and paste the new one in.
Then I did an install of my app (Xerox Docushare) and I still got the
same error. I assumed that the old dll was still loaded into the
system resources, so I crossed my fingers and rebooted the server. It
came back up ok and I then did another install! Presto worked a treat!
Thanks for your assistance! I am very gratefull!

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy