Google Answers Logo
View Question
Q: Wireless Netwoking and the Internet ( Answered,   1 Comment )
Subject: Wireless Netwoking and the Internet
Category: Computers > Internet
Asked by: jim12345-ga
List Price: $10.00
Posted: 30 May 2003 06:25 PDT
Expires: 29 Jun 2003 06:25 PDT
Question ID: 210665
I have a gateway pentium II computer running windows 2000
professional. I had recently connected to a cable internet provider and
it was working well. I then added a wireless router from Belkins and
attempted to connect the desktop through a usb wireless adapter. In
the process I somehow froze the computer on a default IP address of
169. ... I have tried to get the system to release or renew the IP
address but have had no luck It indicate that there is a problem with
winsoc.The result is that I cannot access the Internet with this
computer even when it is connected directly to the cable Modem. I have
had several people look at it and they suggest that I reinstall the
operating system which I would like to avoid.
Subject: Re: Wireless Netwoking and the Internet
Answered By: legolas-ga on 30 May 2003 08:47 PDT
If the computer is showing '169.254.x.x' that means, simply, that the
DHCP server on the router is not functioning. To diagnose, click
"Start" then "Run" and type 'cmd' in the little window and hit 'run'.



you should get ping replies

if not, you'll need to remove ALL network devices/drivers from the
Network applet, reboot as necessary, then READDD everything to the
network applet that's needed. If you need more direction on this step
(if needed ONLY) let me know and I'll walk you through it.

Make sure the USB device is working (i.e. the link light is on on the
usb device and the router). Use a wired connection to the base station
and determine if a WEP password has been set: ensure that the WEP
password is ALSO set on your computer (the exact same password that is
set on the router!). Also ensure that the wireless adapters MAC
address is set in the router: some routers will refuse connections
from wireless cards that are not 'known' to the router.

Also, double check that you have ENABLED the DHCP server on the

The bottom line is that the odds that you'd need to reinstall your OS
is zero. The IP's you're seeing are just telling you that no DHCP
server can be found on the router. It's not 'stuck'. Try what I've
suggested, and let me know in detail what results you are getting.
I'll give you more specific info based on what you report: unless of
course what I suggested (re: WEP passwords, etc) fixed the situation.
Please use the 'request clarification' feature to communicate with me
and please don't close the question by rating it until you are
satisfied with the results.



Request for Answer Clarification by jim12345-ga on 30 May 2003 09:36 PDT
The tcp/ip settings on the connection are set on dynamic assignment.
You missed my point that I cannot connect to the internet now with
router out of the loop and I am connecting the computer directly to
the cable modem via an ethernet adapter. I should add that I have
another computer that does connect to the internet via this same cable

Clarification of Answer by legolas-ga on 30 May 2003 09:53 PDT
Well, depending on how your cable modem registers MAC addresses, the
fact that you can't swap computers on the cable modem isn't out of the
ordinary. Try 'resetting' the cable modem before connecting it to the
new computer. See if it works. Let me know.

Clarification of Answer by legolas-ga on 30 May 2003 10:00 PDT
If you'd like to try one other thing, go ahead and go to the Network
applet in the Control Panel, and REMOVE everything you see there.. All
adapters, protocols and services. Reboot, then (if not detected
automatically), readd everything again. If there is a corrupt file,
that will sometimes help. You will need to reapply the latest Service
Pack after doing that reinstall though.


Request for Answer Clarification by jim12345-ga on 19 Jun 2003 08:14 PDT
Nothing you have suggested is working. Any other ideas?

Clarification of Answer by legolas-ga on 19 Jun 2003 09:07 PDT
Please try connecting the computer to the router using a different
method. i.e. a built-in ethernet card, or a different wireless card.

One other thing you may want to try is to go to the Control Panel,
then, System, then 'hardware' and REMOVE the drivers for the USB
wireless card. Reboot, and reinstall the card as per the
manufacturer's directions. This might be the culprit.

Since you have a 169.254.x.x address it just means they could not
contact a DHCP server so check your network connectivity. If the
networking drivers of your computer were actually not working, you
would get an IP of or an error. This automatic IP addressing
is known as Automatic Private IP Addressing (APIPA).

Please remove and reinstall the drivers for the USB device--that will
most likely fix the remaining issues.


Request for Answer Clarification by jim12345-ga on 19 Jun 2003 11:42 PDT
I have done what you suggest and it does not change the condition. I
think that thesystem software has been corrupted. There is an error
message concerning winsoc when I try to get the ipconfig /release to
release the ip address. I am beginning to think there is not a

Clarification of Answer by legolas-ga on 19 Jun 2003 13:11 PDT
This is the first I've heard about an error message.. Could you please
post it here EXACTLY as you see it?


Subject: Re: Wireless Netwoking and the Internet
From: b_nez-ga on 06 Jul 2003 17:28 PDT
I had a very similiar issue with my 802.11g network this week.  Here
is how I fixed it:
Obtain from your router's configuration utility the DNS server
addresses the server is using.  What you'll do is configure your
computer's TCP/IP settings manually and assign a static IP address. 
Use the router's IP as your default gateway, and use the DNS addresses
you obtained from the router.  This will get you up and running. 
After verifying that everything works, change your TCP/IP settings
back to automatic.  You can create an alternate configuration with the
manual settings, if you like.  After making the changes, the adapter
should be able obtain a lease from the router's DHCP server.  Kinda
weird, but it worked.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy