Google Answers Logo
View Question
Q: ML4500 printer for XP Pro ( Answered 5 out of 5 stars,   0 Comments )
Subject: ML4500 printer for XP Pro
Category: Computers > Software
Asked by: dghn-ga
List Price: $2.00
Posted: 04 Apr 2004 10:53 PDT
Expires: 04 May 2004 10:53 PDT
Question ID: 325018
Does anyone have a printer driver for the Samsung ML4500 for the
Windows XP Pro operating system. Please don't point me to the or websites. Both claim to
have XP Pro drivers but they are NOT - they are in fact Windows 9x and
Subject: Re: ML4500 printer for XP Pro
Answered By: paul_b_18-ga on 04 Apr 2004 11:14 PDT
Rated:5 out of 5 stars
The first method you should try is the following:

Download the Windows XP driver at:

Direct link:
You need to register at to be able to download the
file. Registration is free however.

If this didn't work for you, try the following:

"1. Download the ML-4500 driver for windows 2000 from 
Direct link:

2. Extract the zip file to any folder.
3. Restart Windows. 
4. When prompted with ?found new hardware?, point the wizard to the
ssgk2.inf file you just extracted". Ignore the error it gives after
selecting the .inf file.
Source: "Gripes About Samsung ML-4500 Laser Printer"

After you have installed the driver, Windows XP might find a new
printer everytime you reboot. You can create a workaround for this
problem using one of the following two methods:

1. "The climax of this story is that I fixed the problem by installing
another (virtual) printer and telling Windows XP it was an ML-4600
printer, a model that XP has a built-in driver for. Despite the fact
this is wrong (there was no such printer attached to the computer),
the installation of the non-existant printer went fine and, for
whatever reason, it got rid of the problem of a new printer being
detected at every system startup."
Source: "Gripes About Samsung ML-4500 Laser Printer"


2."Here is the XP solution!!!!! Install the Samsung XP drivers (which
you can download at,
and also extract the Win2K drivers to a folder of your choosing. When
the printer is found on a reboot in Device Manager, choose the install
routine that allows you to go down the "HAVE DISK" option. Point the
location of "HAVE DISK" to the Win2k driver folder you extracted the
2K drivers into, and select the *.inf file in that folder. You will
get 'errors' telling you it's not valid etc, but ignore them. The
printer will then install, and you will not get the "new hardware
found on each reboot" .... please post if this doesn't work for you! I
am using XP Pro SP1"

I hope this solves your problem. If not, don't hesitate to ask for a
clarification. I'm sure I can solve it for you.

Thank you,

Request for Answer Clarification by dghn-ga on 04 Apr 2004 13:52 PDT

Thanks for that. 

It appears that the problem is not the printer driver at all. In fact
I had already tried all your suggestions without success.

Rather, the problem appears to be with my printer port. Here is the diagnosis:

1. My desktop PC (which I upgraded yesterday from 98 to XP Pro) has
never recognised the presence of the printer. This is unlike my new
Dell XP Pro laptop which instantly noticed when I switched on the
ML4500 and offered assistance through the device manager. This way I
was able to install the ML4500 driver on my laptop without a problem.
Not so my desktop.

2. The device manager on my laptop shows yellow exclamation marks over
the LPT1 and LPT3 ports. (This is odd since I only have one printer
port!). Double clicking on the LPT1 the device status reads:

"The device is disabled because the firmware of the device did not
give it the required resource. (Code 29)"

A slightly different message appears for the LPT3:

"Windows cannot dietermine the settings for this device. Consult the
documentation that came with this device and use the Resource tab to
set the configuration. (Code 34)."

When I click the troubleshooter I get scary messages about BIOS
systems. I'm now well out of my depth....!

I have tried re-installing the LPT1 drivers but it says there's is nothing wrong.

Here are my system details:

Op system: Windows XP Pro
Processor: Intel Pentium II (not III)
RAM: 386 MHz
HDD: 6 GB (will be adding more)

I know this is now a completely different question, but one very
worthy of a generous tip if answered:

Can you help install my LTP1 drivers and hardware?

Many thanks,

Cambridge, UK.

Clarification of Answer by paul_b_18-ga on 04 Apr 2004 14:35 PDT
Indeed it's a completely new question but I will try to solve this for you. 
Please be patient as we may require a few attempts. I would also like
to stress that I cannot guarantee that I can fix it and that you
follow my instructions at your own risk: if you absolutely don't know
what you are doing, or don't feel safe about something, don't change

I will give you one possible solution at a time. If the solution
doesn't work, ask for a clarification and we will try something else.

First try the following: disable Plug and Play in your BIOS. 
When you restart your computer, at the very first screen you see,
there is usually something along the following lines:
"Press delete to access Bios (or system setup)".
It might also be F5 or something. Anyway, at that moment you have to
press that key and you will get into your bios.

Be carefull what you do in your BIOS: if you change settings which
shouldn't be changed, your entire computer might get messed up. Just
browse through the different options/menus untill you come along the
"Plug and Play" option. Then make sure it's disabled. Exit and save
your bios.

Let me know if this solves your problem.


Request for Answer Clarification by dghn-ga on 04 Apr 2004 14:47 PDT

In the meantime I have been uninstalling the LPT port using the Device
Manager, switching the PC back on, watching as Plug and Play notices
the presence of the new hardware and then it re-installs the Parallel
Print driver. This all works fine.

However, when I go into the Device Manager I find that the
re-installed LPT3 port says "This device can not start. Code 10.".

Back to square one.

For some reason the PC just can not correctly install the LPT -
despite the fact it has been working perfectly under Windows 98 for
the past five years!

Right, now I'll try your BIOS suggestion.

Thanks again.

Clarification of Answer by paul_b_18-ga on 04 Apr 2004 14:49 PDT
Possible solution number 2:
Again you have to access your BIOS. See if you can find the settings
for the LPT port. Make sure it is enabled. (it should not say "auto"
or "disabled"; if it does, change it to "enabled".

After you have changed any settings in your BIOS, and the ports still
don't work, remove both LPT 1 and 3 in your device manager (right
click on them and select "delete"). Then restart.

Let me know if this solves your problem.
dghn-ga rated this answer:5 out of 5 stars and gave an additional tip of: $10.00
Pure genius. I am completely astounded. Why didn't I find this guy 17
bloody hours ago!!!

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy