Dear scaryberry-ga,
The configuration you want should be as follows:
ip subnet-zero
no ip domain-lookup
!
interface Serial0
description connected to T1 line
ip address 10.0.0.1 255.255.255.252
encapsulation hdlc
################## Next line is the DCE line (see below)
clock rate 1300000
################## Remove these comments before use.
service-module t1 timeslots all
no cdp enable
no shutdown
!
interface FastEthernet0
description connected to local network
ip address 192.168.5.254 255.255.255.0
no cdp enable
no shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0 permanent
!
no cdp run
!
end
Note: This configuration file just includes the commands to configure
the router's interfaces and the routing between them (it also disables
the Cisco Discovery Protocol on them, which is usually a good idea for
security purposes); for practical purposes, you'd also want to set
passwords on the router to prevent unauthorised access:
service password-encryption
aaa new-model
aaa authentication login default local
aaa session-id common
enable secret [enable password]
username root password [access password]
(If you enter these configuration commands manually, then save the
running configuration to a configuration file:
copy running-config startup-config
then the passwords will not appear in the configuration file.)
The command to set the Serial0 interface as DCE is the "clock rate"
command, which also sets the speed of the interface:
"This command sets the interface's line speed to 56Kbps. Most Cisco
synchronous serial interfaces can support line speeds between 1.2Kbps
and 4Mbps, although they generally only accept specific round number
values rather than arbitrary values: 1200, 2400, 4800, 9600, 14400,
19200, 28000, 32000, 38400, 56000, 57600, 64000, 72000, 115200,
125000, 128000, 148000, 192000, 250000, 256000, 384000, 500000,
512000, 768000, 800000, 1000000, 1300000, 2000000, 4000000 and, on
interfaces that support higher speeds, 8000000. Note that there is no
conventional T1 setting at 1544Kbps; the closest substitutes for a T1
are 1300 or 2000Kbps. This is usually not an issue, however, because
in real carrier-provided T1 circuits, the carrier's equipment
generally supplies the clock.
But this clock rate command has another important effect. Because only
DCE interfaces can supply the clock signal on synchronous serial
connections, configuring this command on an interface implies that
this interface is the DCE device. If you want the router to be a DTE
device, you must omit the clock rate command."
- Cisco Cookbook, O'Reilly & Associates, ISBN 0-596-00367-6
Also, you mention that your WIC has an on-board CSU/DSU. The
"service-module" command configures this for use with a full T1 (all
timeslots used); it should work with a "standard" T1; however, if your
T1 uses certain less common configuration options, you may need to
specify additional options, documented here:
Interface Commands (loopback remote - service-module t1 remote-loopback)
http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_command_reference_chapter09186a00800880db.html
This should work fine for you. If you have any questions, or run into
any problems implementing this configuration, please feel free to
request a clarification.
Regards,
cerebrate-ga
Search strategy:
Cisco Cookbook, O'Reilly & Associates, ISBN 0-596-00367-6 (via Safari subscription)
http://safari.oreilly.com/
Google Search - "service-module t1"
://www.google.com/search?sourceid=navclient&ie=UTF-8&oe=UTF-8&q=%22service%2Dmodule+t1%22 |