Google Answers Logo
View Question
Q: USB Issues Windows 2000 SP4 ( Answered 1 out of 5 stars,   3 Comments )
Subject: USB Issues Windows 2000 SP4
Category: Computers > Operating Systems
Asked by: belhanj-ga
List Price: $50.00
Posted: 14 Aug 2004 19:05 PDT
Expires: 13 Sep 2004 19:05 PDT
Question ID: 387954
Every time I attempt to install a USB device such as a generic hub or
a keypad, the install fails. It appears as if Win2k is unable to
determine what kind of device it is.

The error message that I receive is 

Complete the found new hardware wizard
USB device
An error occurred during the installation of the device
The installation failed because a function driver was not specified
for this device instance

Then of course the device is found in the device manage with a yellow
exclamation point. No matter how many times I uninstall the device and
retry the device the same thing occurs. This is true for my HUB,

When I right-click on the device, and click properties, I receive a
CODE 28, drivers are not installed.

When I look at all my devices in the device manger (including hidden),
I also find a yellow exclamation point next to

When I right-click this driver the message that is show is

This device is not present, is not working properly, or does not have
all its drivers installed. (Code 24)

There is also a yellow exclamation point next to PARPORT; but I don?t
think this has anything to do with this issue.

Now I have already done an in place refresh of Windows 2000 and this
didn?t resolve the issue. I also have all the service packs installed.

Any ideas?

Request for Question Clarification by clouseau-ga on 14 Aug 2004 19:46 PDT
Hi belhanj,

Have you checked the CMOS (BIOS) to be sure USB is turned on there?

Let me know the reuslt of checking this, usually by hitting the DEL
key upon boot and looking through the pages for USB settings, If this
is activated, I will look further for you. But this is the first thing
I would check.



Clarification of Question by belhanj-ga on 14 Aug 2004 21:09 PDT
Have you checked the CMOS (BIOS) to be sure USB is turned on there?

The only setting found in the bios is an option for USB legacy
support. It is enabled. I have attempted to disable and re-eanble it
to see if this would make a difference, but it did not.

Currently it is set to enable.
Subject: Re: USB Issues Windows 2000 SP4
Answered By: clouseau-ga on 14 Aug 2004 21:56 PDT
Rated:1 out of 5 stars
Hello belhanj,

You are not alone with this problem. Many users report the same with a
variety of devices and motherboards. However, it seems the solution
might be as simple as that contained on this page:

Follow their instructions and you are likely to be successful as it
appears that the driver loaded is not the proper version for Windows

"function driver not specified

Thursday, 18 March 2004

Are you having problems with installing USB devices?

You have installed it as per the instructions?

You have tried to install or reinstall the driver and each time it
comes up with the error ?Installation failed because function driver
not specified'?

Is there a yellow exclamation mark against the device in ?My
Computer?, ?Device Manager??

I was trying to install a pen/tablet on a windows 2000 pc and it just wouldn?t run.

The light on the tablet flashed all the time.

With the assistance of a very knowledgeable technician at Epson who
was supposed to be helping me with printer font issues, we have
managed to fix the problem.

The problem turned out to be that windows had chosen the wrong inf
file to load. In my case it chose the Win98 version..."

Read their instruction for fixing this problem.

You will also find this article on USB problems in Windows 2000 informative:

Most important is this (which is echoed on many other sites):


"The installation failed because a function driver was not specified
for this instance"

This message may be displayed when attempting to install the USB modem
driver if an existing driver is already installed (or not yet removed)
from Windows 2000. Remove the existing driver before attempting to
install the new driver...."

So, having the wrong driver selected from the wrong .inf file is
usually not repaired by selecting the proper .inf file until the
original driver has first been removed. Best to reboot after removal,
then install using the proper .inf file from the Windows 2000
directory on the driver CD.

I have a high level of confidence this will solve your problem if all
of the failed instances are removed. See the following threads for
additional and similar discussions of this problem:

There are dozens and dozens of similar threads peppered about on the
web. In short, they all come down to the wrong driver being installed
for Win2K and then stuck even when trying to be overwritten With the
correct driver. Try the suggestions above and let me know if the
problem continues. You may have to seek out the most current Windows
2000 driver for a device or two if they are not on your CD's or have
been updated to eliminate this problem.

Search Strategy:

"function driver was not specified"

I trust my research has provided you with a workable solution. If a
link above should fail to work or anything require further explanation
or research, please do post a Request for Clarification prior to
rating the answer and closing the question and I will be pleased to
assist further.


belhanj-ga rated this answer:1 out of 5 stars
It looks as if this particular issue is beyond the realm of the
answers suggested. I have gone ahead and just reinstalled Windows from

Subject: Re: USB Issues Windows 2000 SP4
From: reason47-ga on 07 Dec 2004 21:29 PST
fwiw:  I had a similar problem with a USB card reader that I had
plugged into the case-front.  I finally ran across this link:;action=display;threadid=7460

which (at the time of my reading) contained the text:

"It's often due to poor quality cable between the motherboard and the
case also if the distance is too long. It's can occur if the usb
connector are not placed correctly or firmly. Sometime the device
doesn't receive the signal or correct voltage and then will not be
reconized correctly"

Based on this, I moved the card reader to the a USB port that was
directly on the motherboard... and it magically started to work.

Your mileage may vary.
Subject: Re: USB Issues Windows 2000 SP4
From: isapdcm-ga on 22 Jan 2005 02:55 PST
I had the same problem with my Fujifilm usb digitial camera. W2K kept
'finding' a more appropriate driver to install. I followed the advice
referred to in clouseau's first link and moved the file W2K was
finding (in the C:\WINNT\Inf folder) somewhere else (make sure to move
rather than copy or W2K will still find it - like I did first time
around). The driver wizard then 'found' the correct driver file (which
in my case I had downloaded from the Fuji site). Worked perfectly.
Subject: Re: USB Issues Windows 2000 SP4
From: ncw_bmw-ga on 25 Jan 2005 11:08 PST;amp;amp;displaylang=en&familyid=7c896e82-4b50-44c8-a634-3227c0e71293&displaylang=en
<a href=";amp;amp;displaylang=en&familyid=7c896e82-4b50-44c8-a634-3227c0e71293&displaylang=en">Link
This is address by microsoft after certain security patch, and or
service pack 4 is loaded on windows 2000


Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy