Google Answers Logo
View Question
Q: PPPoE connection problem in China ( Answered 5 out of 5 stars,   4 Comments )
Subject: PPPoE connection problem in China
Category: Computers > Internet
Asked by: santabarbara-ga
List Price: $25.00
Posted: 13 Sep 2004 10:46 PDT
Expires: 13 Oct 2004 10:46 PDT
Question ID: 400607
I am using a Macintosh OS 10.3.5 and I cannot access most U.S. based web pages
using a PPPoE connection in China. In the network connection log, I
get the message "IPV6CP: timeout sending Config-Requests" When a PC
running Windows uses my same PPPoE connection, there is no problem
connecting to web pages. I can connect fine to pages in Beijing but
not in the U.S.A. like CNN.COM. A dialup modem connection to surf the
internet works just fine. What is the problem with my settings or is
it a server problem? What do I tell my Internet Provider to fix?

Clarification of Question by santabarbara-ga on 13 Sep 2004 11:21 PDT
One other clue: I used Eudora to get my mail, and when using the PPPoE
connection described above, Eudora connects succesfully to the server
and see that there are messages to be downloaded, and Eudora just
stops, it cannot continue to download the messages it sees on the mail

Request for Question Clarification by aht-ga on 16 Sep 2004 00:01 PDT

Networking and ISP problems like this almost always take several kicks
at the can to solve, so I'll start this off as a clarification request
first, so that we can find out more about the root cause of the

My first suspicion is that there is a MTU size difference between your
Mac and your ISP. The default MTU (Maximum Transmission Unit) for Mac
OS X is 1500, which is also the default MTU size for an Ethernet
connection. Windows will query the adapter for the MTU size and adjust
itself. If there is a difference in the MTU size between what your Mac
is expecting, and what is actually in use, then you can experience the
symptoms that you have described.

Please consult the following page for more information on using PPPoE
with Macs (including a link to a utility to let you adjust the MTU
size for OS X):

Try using the RMAC utility to adjust your MTU, first to 1492, then, if
that doesn't help, to 1450. Let me know if this helps.


Google Answers Researcher

Clarification of Question by santabarbara-ga on 17 Sep 2004 01:34 PDT
You were right aht-ga! I downloaded the RMAC utility and adjusted the
MTU down to 1438 and things worked fine. I now understand that MTU is
"maximum transfer unit" which is usually 1500 for ethernet, but I do
not understand why my two Macs worked for almost three months and then
suddenly they no longer worked on China Telecom. What did they
possibly change of their system to make it not compatible with Mac.
What should I tell the China Telecom people to change on their server?
They say they no nothing about Macs, but in this case, maybe other
computers will not work becuase of the MTU problem.

And by the way, no one else here in Beijing knew what the problem was,
even the "genius" at the Apple Store and the President of the Beijing
Mac Users Group. You win the $25 prize and I am very grateful!
Subject: Re: PPPoE connection problem in China
Answered By: aht-ga on 17 Sep 2004 07:38 PDT
Rated:5 out of 5 stars

I'm glad to see that the first attempt was the only attempt needed!
Whenever I run into an intermittent connectivity or timeout issue, I
first check for a physical cause (loose cable, power supply, etc),
then the next things I check are the parameters for the network
connection, with the MTU size being foremost among those when dealing
with an ISP.

The PPP-over-Ethernet 'standard' typically calls for a maximum MTU of
1492 (versus 1500 for a standard Ethernet connection... some overhead
there). However, since the MTU size you need to use is established by
the maximum packet size that all of the routing equipment between you
and your destination can handle, the optimal MTU size can be anything
but standard. For example, check out this page in the FAQ:

As you'll see from there, the ISP can choose to use a smaller MTU size
in their configuration of their network devices. The trade-off that
they are trying to balance is between efficient communications for
each individual end-user, and the amount of lag for all users as the
routing equipment can only handle so many requests at a time.

So, why were your Macs fine at first? The answer will be extremely
elusive, and can reside anywhere along the networking connection
between you and the websites you are viewing. Has any equipment in
your office changed? Has your ISP (China Telecom) performed any
maintenance or upgrades on their subscriber-facing equipment in their
local central office? Perhaps they have upgraded their routers, and
lowered the max MTU level in the process. Or, it might even be that
the gateway routers controlled by the Chinese government that allow
access to international networks, have increased overhead requirements
due to increased censorship. It's really hard to say.

The most likely place to look, is the part of the connection that lies
within your own office, followed by the equipment at the other end of
your physical connection (which I am thinking is DSL?). Do you have a
router in your office? If so, that router has a max MTU setting which
may not be properly communicated back to your Macs (but is being
communicated back to the network adapters in your Windows machines).
Or, China Telecom may have upgraded their equipment in the local
central office that manages the PPPoE session(s), and may have lowered
the MTU setting there. If the 'bottleneck' were further on in the
network, then I would expect to see problems on the Windows machines
as well.

Since the root cause of the problem might never be found, its probably
best to keep the RMAC utility close at hand on any Mac you may use for
Internet access; I'd even consider keeping it on portable media in
case any of the other Mac users you know ever run into this problem
too. Again, the link to the information page that links to the tool

I'm glad that I was able to help you with this problem, and hope that
your Internet surfin' remains easy and trouble-free! (Or at least as
trouble-free as it can be given your location!)


Google Answers Researcher

Clarification of Answer by aht-ga on 17 Sep 2004 07:50 PDT

One additional thought that I should mention. If there is indeed a
router that is in use in your office, that router will negotiate with
your computer to determine the maximum MTU size during the initial
'handshaking', or discovery stage, that goes on when your computer is
initially connected to the network. There may be an issue here with
the configuration of that router and how it negotiates the max MTU.
So, if there is indeed a router present, you (or the person who
manages the router) may want to look into its configuration to see if
something is misconfigured.


Google Answers Researcher
santabarbara-ga rated this answer:5 out of 5 stars
In a city of 14 million where no one else had a clue, aht-ga came to the rescue!

Subject: Re: PPPoE connection problem in China
From: scriptor-ga on 13 Sep 2004 11:00 PDT
It may have something to do with the fact that the Chinese government
uses numerous kinds of censorship technologies.

Subject: Re: PPPoE connection problem in China
From: santabarbara-ga on 13 Sep 2004 11:24 PDT
I thought of that possible problem but why would they allow a Windows
machine to see web pages like CNN but a Mac using the same connection
does not work? And a dialup connection works just fine and connects to
any web page I want.
Subject: Re: PPPoE connection problem in China
From: jdragon2k-ga on 15 Sep 2004 16:38 PDT
I thought you must be in the university or some research network, not
a public common network. In the first network, you can't access
foreign sites without using a proxy. The dial-up service is always
provided by china telecom company, and it is public common network, so
you don't have any problems.
Subject: Re: PPPoE connection problem in China
From: santabarbara-ga on 15 Sep 2004 18:27 PDT
I am on a public network in an office building using a LAN connection.
I am not using any proxies. A guy at the Apple computer store in
Beijing says that there is some kind of difference in the data packets
accepted on a Mac vs. Windows and China Telecom may not know how to
configure their system to send data universally. Does anyone know the
difference between Mac and Windows data being sent over TCP/IP?

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy