Google Answers Logo
View Question
Q: Disabling Windows XP Hotkey for Keyboard Layout Swapping ( Answered 4 out of 5 stars,   0 Comments )
Subject: Disabling Windows XP Hotkey for Keyboard Layout Swapping
Category: Computers > Operating Systems
Asked by: modus-ga
List Price: $5.00
Posted: 13 Oct 2004 12:51 PDT
Expires: 12 Nov 2004 11:51 PST
Question ID: 414358
I am running Windows XP on a Japanese laptop.  From time-to-time, I
hook up an external keyboard to the system which has an American
layout.  So, I have both American and Japanese keyboard layouts

Every once in a while, I'll hit a keystroke combination that switches
me from one keyboard layout to the other.  I'd like to know what this
keystroke combination is and how I can disable it entirely.

Please note that I am not switching input methods (left alt + shift). 
The input method remains English, just the keyboard layout switches.

Subject: Re: Disabling Windows XP Hotkey for Keyboard Layout Swapping
Answered By: aht-ga on 14 Oct 2004 07:02 PDT
Rated:4 out of 5 stars

The standard key switch for the keyboard layout is Ctrl + Shift.
Extremely easy to hit by accident.

The setting is controlled from within the Regional and Language
Options applet on the Control Panel. Please take the following steps:

- Go to Control Panel>Regional and Language Options
- Select the Languages tab
- Click the Details... button in the "Text services and input languages" section
- Confirm that you indeed have both "Japanese" and "US" entries in the
Keyboard section under the English section
- As long as you have at least Japanese and US keyboard types created,
click on 'Key Settings' in the Preferences section
- there are two items to look for in the 'Hot keys' list:
  - if you see entries for "Switch to English (US)" for different
keyboard languages, ensure that the key sequence for each has been
cleared by clicking on the "Change Key Sequence" button after
highlighting each, and unchecking the "Enable Key sequence" checkbox
in the window that appears
  - as well, highlight the "Switch between input languages" action,
and again hit "Change Key Sequence"; you should see a checkbox for
"Switch keyboard layouts" that you will want to uncheck
  - while you're here, you may want to consider disabling the "Switch
input languages" checkbox as well, unless you are actually using it

This should do it for you, but if you run into a problem, please let
me know using the "Request Clarification" button above.


Google Answers Researcher

Request for Answer Clarification by modus-ga on 14 Oct 2004 07:26 PDT
ctrl-shift is the keystroke, but my system lists all of the hotkeys,
except for ctrl-alt to switch input methods, as "disabled".  Any

Clarification of Answer by aht-ga on 14 Oct 2004 07:43 PDT
Did you highlight the "Switch between input languages" action and
click "Change Key Sequence" to confirm that the checkbox in there for
switching keyboard layouts has also been disabled?

Request for Answer Clarification by modus-ga on 14 Oct 2004 08:31 PDT
I see what you mean.  The left checkbox ("Switch Input Languages") is
checked.  The right checkbox ("Switch Keyboard Layouts") is not

Despite this, ctrl-shift still switches keyboard layouts.

Clarification of Answer by aht-ga on 14 Oct 2004 08:57 PDT
You may need to reboot for the setting to take effect... have you already done so?

Request for Answer Clarification by modus-ga on 15 Oct 2004 06:03 PDT
It was actually already set to disabled even before I tried to change
it.  I just did a reboot to make sure, and no dice.  ctrl-shift still
causes a keyboard layout swap.

Any other thoughts?

Clarification of Answer by aht-ga on 15 Oct 2004 10:05 PDT
The only place that this key-combination is supposed to be defined in
a standard XP installation is right there in the Key Sequence for
switching languages. So, this is puzzling. Can you try this and tell
me what happens:

1. With no external keyboard attached, go into the Language settings
and visually confirm which keyboard layout is active (its the one in
Bold), and go back into the Key Sequence settings to reconfirm that
the key combination for changing keyboard layouts is NOT active

2. On the Languages tab, click on the Language Bar... button and check
the boxes for displaying the bar on the Desktop, and for showing the
additional icons.

3. Click OK to close all the control panel applet dialogs

4. Hover the mouse pointer over the keyboard icon in the language bar,
and see what layout is currently active

5. Hit Ctrl-Shift, then hover over the icon again to see if the layout
changed; if it has, there has to be some other program that's trapping
the key combination and issuing the change

6. Look in Control Panel>Keyboard to see if somehow a 3rd party driver
has been installed for your keyboard that has its own switches


Google Answers Researcher

Request for Answer Clarification by modus-ga on 15 Oct 2004 10:29 PDT
Thanks for your reply.

I've double checked the settings as you suggested and disconnected my
external keyboard.  Ctrl-shift stills causes the keyboard layout to

My keyboard control panel only has the 2 standard tabs in it.  With
the external keyboard disconnected, the driver is still for an "Easy
Internet Keyboard" (my external Logitech keyboard).  I will try
swapping that back to the standard Japanese 108 keyboard driver and
see if that changes anything.

Clarification of Answer by aht-ga on 15 Oct 2004 12:18 PDT
I've looked to see if MS had identified any similar problems in their
Knowledge Base, unfortunately there isn't anything useful there. I'll
keep looking, but right now it looks like there is something
non-standard about how the keyboard shortcuts are being handled on
your PC.
modus-ga rated this answer:4 out of 5 stars
Was able to answer half of my question, but not the other half.  I
feel like I got more than $5 worth of the researcher's time, even
though I didn't get the full answer I was looking for.

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy