Google Answers Logo
View Question
Q: Windows being full size in Windows programs ( Answered 5 out of 5 stars,   2 Comments )
Subject: Windows being full size in Windows programs
Category: Computers > Software
Asked by: pendleton-ga
List Price: $2.00
Posted: 12 Sep 2002 15:20 PDT
Expires: 12 Oct 2002 15:20 PDT
Question ID: 64425
I have PC's with Windows 98 and 2000 professional. I am so frustrated
that when I open a Windows document or an email in Outlook or a Web
site in Explorer that it is not full screen. I have click on that
little square to make it full screen. There has got to be some nice
way to configure my PC's that when I open a document, email, web page
it will be full screen.

Your question today is: HOW DO I DO IT?
Subject: Re: Windows being full size in Windows programs
Answered By: deadlychiapet-ga on 12 Sep 2002 18:40 PDT
Rated:5 out of 5 stars
Hi there,

It's always annoyed me when IE windows don't open maximized, so a
while back I found a program that does just that. It's called IE New
Window Maximizer (naturally ;), and can be found at The program is freeware,
but the author does ask that you pay for it if you use it longer than
21 days.

However, while searching for you today I found a program that goes
beyond IE windows and appears to do just what you want. It's called
Autosizer (, and basically what
it does is it maximizes (but it can also be set to minimize, center,
or restore) any newly opened windows. The only drawback to this
program is that you need to set it up for each program you use, but
once that's done it should work just fine.

These programs need to be running all the time to do their magic, but
they do run unobtrusively down in the system tray and take up minimal
system resources.

I hope that's what you're looking for! If not, please feel free to ask
for clarification.

Google search terms used:
IE new window maximizer
maximize new windows
automatically resize windows

Request for Answer Clarification by pendleton-ga on 03 Oct 2002 19:15 PDT
I still cannot get it to work. 
I right clicked on Explorer and no Run: came up in the properties list.

I did "My Documents"--- Same.

I have supposedly (I could be wrong) done everything right to get for example,
Microsoft works to always open maximized. No go.

I am not sure I understand the "Class name", "must match exactly" and such.

More clear step by step help.

Clarification of Answer by deadlychiapet-ga on 04 Oct 2002 20:05 PDT
In regards to the method in the comment below. This will work for most
shortcut icons that can be found in the start menu and on the desktop,
but not all of them (notably the special Internet Explorer icon, My
Network Places or Network Neighbourhood, and My Computer).
To use this method, what you need to do is this. Right click and click
on properties. It should pop up the properties window for the file
with the Shortcut tab open. If you have some other tab selected, click
the Shortcut tab at the top of the box. On this page you should see a
drop down box called Run. It should have three options: Normal Window,
Maximized, and Minimized. If you change it to Maximize and then click
Okay or Apply at the bottom of the screen it should set the program to
always open up maximized when you use that shortcut.
The main limitation of this method is that you need to set it up for
each and every shortcut in both your Start Menu, Desktop, and any
other toolbars you might have around the screen. As well, as mentioned
above it won't work on certain special shortcuts.
Now, for the Autosize program. Open it up and we'll go step by step
through it.
You should be presented with the program's main window when you open
it up. Click the Options button at the bottom of the screen and under
General make sure there's a checkbox beside Load AutoSizer every time
Windows starts, then click okay.
Next, here's what you need to do to set a program to always open
maximized. While you have AutoSizer's main screen open, open any
program, lets say Internet Explorer. Under Currently Open Windows you
should see the title of whatever IE window you have open. While at
Google Answers it might say "Google Answers - Microsoft Internet
Explorer". Beside that you'll see which Class that window belongs to.
For IE the class is called IEFrame (in Windows XP anyways, it could be
different in Windows 98/2k). If you're confused about what a class is,
just think about it as the type of Window that's open. Every IE window
open will have the same class, so if AutoSizer is set to maximize a
certain class it'll maximize every IE window.
Now, to set IE to always open up maximized, click on the Internet
Explorer entry under currently open windows and click the AutoSize!
button. Once you click the button you'll be prompted on what you want
to do. All you really need to do is click okay and you should be set.
By doing that it'll be set to search for and maximize windows by class
(ex. it won't matter what your IE title bar says, it should still
maximize it.)
You can repeat this procedure for any program and it should work (Open
program, select entry, click AutoSize button, click okay).
If by chance you have a strange program that just refuses to work
while set to the default Compare using class name, but it always has
the same title or at least the same part of title, you can change it
to Compare using Window Title. You can set it so it has to match
exactly what it says in the Window Title box above (ex. if "Untitled -
Notepad" is set for exactly, that's all it will open), or so it has to
contain what it says above (ex. if you just put "Notepad" in the
window title box when it's set for this option, it will open "Untitled
- Notepad" or "File1 - Notepad" using the same rule.)
If after you set up a Window and it doesn't work try restarting your
computer and make sure AutoSizer is running (it should appear down in
your system tray as a white square with red arrows in the corner).
Then open the program, it should work. If not, open up AutoSizer and
make sure you have it set up right.
I don't have MS Works on this comp, but I imagine the entry under
Windows Targeted by AutoSizer would look like "Microsoft Works". If
it's not there, try opening up works, make sure you click on Microsoft
Works in the top part of the screen, click AutoSize, and click okay.
It should maximize itself right away.
I hope that clears things up for you! =) 
pendleton-ga rated this answer:5 out of 5 stars
You did an excellent job of finding, answering and "stepping" me
through the process. I think that this program does not work with
Windows 2000 professional.

As far as I know I did everything right, tried different ways and
still my IE and MS Works do not open to full page.

Thank you for trying and working with me.
You deserve 5 stars for your diligence.


Subject: Re: Windows being full size in Windows programs
From: inquisitor-ga on 12 Sep 2002 15:42 PDT

To fix your problem click on any icon on your desktop With The Right mouse button.
A little menu opens up. Click on properties with the regular mouse button.
In the window that opens look at the Run: field and pick Maximized as your choice.


Subject: Re: Windows being full size in Windows programs
From: s_milberg-ga on 12 Sep 2002 15:57 PDT
You can also use the keyboard shortcut sequence to maximize windows:

ALT + space, x

meaning hold ALT and space together, let go, press x

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy