Google Answers Logo
View Question
Q: what is meant by this error msg from ImageMagick on Linux? ( Answered,   0 Comments )
Subject: what is meant by this error msg from ImageMagick on Linux?
Category: Computers
Asked by: cgn-ga
List Price: $2.00
Posted: 03 May 2006 13:21 PDT
Expires: 02 Jun 2006 13:21 PDT
Question ID: 725189
Working on Fedora Linux, I'm trying to create an mpeg file with
ImageMagic using the command

convert f*.jpeg f.mpeg

where the jpeg images for the frames are in f0000.jpeg, f0001,jpeg, etc.
I get a slew of warnings that I don't understand:

[greg greg] convert f*.jpeg f.mpeg
Warning: setting constrained_parameters_flag = 0
Encoding frame 0 .........................
Encoding frame 1 .........................
vbv_delay underflow! (decoding_time=22400.0, t_EOP=31450.0
)vbv_delay underflow: -5457
Encoding frame 2 .........................
vbv_delay underflow! (decoding_time=26000.0, t_EOP=60965.0
)vbv_delay underflow: -31372

I also get an output file f.mpeg, but I'm not sure if it is valid.

1) What do the warnings mean?
2) How can I test whether the mpeg is valid?

Greg Nelson
Subject: Re: what is meant by this error msg from ImageMagick on Linux?
Answered By: maniac-ga on 03 May 2006 18:45 PDT
Hello Cgn,

The message basically indicates that the frame differences are "too
complex" to process. There are several messages on the "magick-users"
mailing list that describe this problem. A search phrase in Google
like convert vbv_delay
will give you several messages that describe the problem / work
arounds. You may want to subscribe to this mailing list at
to get insight into improvements to the product, other problems to
avoid, and so on.

The mpeg you generated will likely not look very good (play it with
one of several video players to see this).

There are a few ways you can work around this problem:

[1] Increase the number of frames / jpeg images so the differences are less.

[2] Add -delay ### (### represents the number of 1/100ths of a second
to delay between each frame) to the convert command line. See
for an explanation of this option and the others. Setting -quality, or
-sampling-factor may also help.

[3] Using mpeg-2 instead of mpeg-1 may also help (.m2v) avoid this
problem / allow faster frame rates. See
for a listing of the file types supported by ImageMagick.

Search phrases used to help generate this answer include:
  site:imagemagick vbv_delay

Good luck with your work.

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy