Google Answers Logo
View Question
Q: Troubleshooting Nvidia TwinView on Ubuntu Linux ( Answered 5 out of 5 stars,   0 Comments )
Subject: Troubleshooting Nvidia TwinView on Ubuntu Linux
Category: Computers > Operating Systems
Asked by: nevada2244-ga
List Price: $100.00
Posted: 23 May 2006 14:16 PDT
Expires: 22 Jun 2006 14:16 PDT
Question ID: 731784
Any X experts out there? I need help setting up Nvidia TwinView on an
Ubuntu Linux machine.

In order for me to pay the big bucks, my machine must reliably boot
from a Linux distribution with TwinView working!!! That is, a single
desktop across two monitors.

My motherboard is an ASUS A8N32-SLI, my video card is an ASUS EN7800
GTX. I have 64-bit Ubuntu Breezy installed.

Here's the fun part - the Nvidia 1.0.8756 driver installs
successfully. I then let nvidia-configx run. No errors. Then if I do
startx, X starts with TwinView working! Great!

Then when I reboot, X fails. I've edited the xorg.conf files many
times to try to eliminate errors, but I must still be missing
something. Since TwinView works after the driver is installed, the
hardware should be OK.

My current xorg.conf is here:
My current xorg.0.log is here:

These are only the current versions. I've tried many other versions before these.

I'll take whatever advice you give and report back results until
something works. I assume this will take a few exchanges back and
forth. This is a new system install, so there is no data to lose. I'd
like to stick with Ubuntu or at least some other Debian-based distro.
My hope is that I'm just missing some small thing in the xorg.conf
file. But I'm completely lost as to how this could work on
installation and then not work after rebooting.

(I'm out for the rest of today. Will check back first thing tomorrow.)



Request for Question Clarification by maniac-ga on 23 May 2006 17:59 PDT
Hello Nevada2244,

Hmm. It sounds like the configuration tool (nvidia-configx) is setting
up the card differently than a cold boot. A few things to try.

[0] I suggest adding something like...
  export NOWIS=`date`
  mv Xorg.0.log "Xorg.0.log.$NOWIS"
to capture each log file with a unique name prior to starting X. You
could leave this in permanently if you rm the old files (say - after a

[1] Are there any differences in Xorg.0.log between the successful and
unsuccessful runs? The diff output may be quite illuminating.

[2] Since you don't get either (WW) or (EE) lines prior to the SIGSEGV
(signal 11) - the X server code isn't finding the real problem. Try
trapping the error by running gdb on the X server. There are at least
two ways to do this:

  (a) debug using the core dumps. See
for a pretty good explanation of the steps involved

  (b) debug on line (suggest you use a serial interface or network
login for this method). You can attach while the X server is starting,
or start the X server by hand with gdb. The same reference as above
describes the attach method. Starting the X server by hand requires
some voodoo magic, and I'll have to do some further research to get
the exact steps.

If you have symbols loaded, you should get a good indication of the
cause of the failure (at least the function / module it occurs in) and
can report that back. If you don't have symbols - let me know and I'll
see if I can find some version that does for you to test with.

[3] Try disabling some features. It looks like you disabled the second
monitor in your test, but it seems to be incomplete (e.g., TwinView is
still enabled). Disabling glx (hardware acceleration) support might
help as well.

It also appears odd that the log file also refers to Xinerama
(multiple monitors act as a single desktop) as a loadable module and
built-in. Something is fishy there but I'll have to do some research
on that.

See also this note
Another user reported that the nvidia software wasn't all in the right
locations. You may check your system to see if this is your problem as


Clarification of Question by nevada2244-ga on 24 May 2006 10:22 PDT

I tried turning off "Load glx" in the conf file and it looks like it's
working. (It's the installer that put that line in there, not me!)

My current log (on successful booting) is here:
My current conf file is here:
This is my edited "best try" conf file after my own study, not nvidia's xconfig.

A few questions:

1. In the current log file I see these lines:

   (II) Loading extension NV-GLX
   (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
   (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

What? GLX IS being loaded, even though it's commented out in the conf
file? Any guess what was happening? The driver can't figure this out?

2. Also in the log file, there's still a warning

   "More than one matching Device section for instances"
Is it because I specify a device for each screen? How can I eliminate
this warning?

3. Any other comment regarding the xorg.conf file?

4. Also in the log file I still see, as you did:

   (II) Loading extension XINERAMA
I'm curious if you found out anything about this. I don't think it's important.

Thanks for taking on this question. I'll see what happens when I
reboot tomorrow morning before declaring final victory, but we might
have it!

Request for Question Clarification by maniac-ga on 24 May 2006 16:47 PDT
Hello Nevada2224,

It is good that progress has been made. Let me comment first on the
new questions / comments and then I'll follow up with a few more
things to check.

[1] Loading NV-GLX, etc. 

This appears to be a side effect of the NVIDIA module loading. The
documentation I looked at on Nvidia's site talks about loading of
other modules, etc. As to why it still says it is using this
capability is beyond me [may be a bug...].

[2] More than one...

The configuration file refers to Device "NVIDIA Corporation NVIDIA
Default Card" twice (one for each screen). It is an info message so
its MAY be OK. Searching for that phrase on various mailing lists
doesn't bring up much of a hint on why you would get that. Since you
are using Twinview, it might not be necessary to actually specify both
screens - see
for details. See also
which describes the set up of two X displays on the single card (not
using Twinview).

[3] Other comments.

The error messages [those marked with (EE)] indicate GLX is not loaded
and the driver considers this an error. I suggest checking that all
files are the Nvidia ones as described at
(scroll down to appendix C) or more directly at
which describes the files, links and specific versions and locations.
If you have to fix something, try enabling GLX again to see if it is
completely fixed.

[4] Xinerama messages...

Again, based on the Twinview section of the README
(search for Xinerama) it mentions that the Xinerama interface is used
to allow the window manager (and other applications) find out the
edges of the two displays. It looks like this is "normal behavior".


I suggest you briefly view
where another user has a similar problem / uses the "disable GLX"
solution to make it work. This was over a year ago and I find it odd
that you have the same problem with the updated driver.

As a side note - in addition to the reboot, I suggest doing it twice:
 - once with power off / on
 - once without power off / on
to make sure the configuration works on a completely uninitialized
card (after power off) as well as the indeterminate state the card is
in when you reboot.


Request for Question Clarification by maniac-ga on 31 May 2006 11:27 PDT
Hello Nevada2244,

Did you declare success?

If so, I would like to prepare a proper answer.
If not, please describe the current situation so I can help you correct it.


Clarification of Question by nevada2244-ga on 02 Jun 2006 09:49 PDT
Hi Maniac,

I did an apt-get upgrade, X failed, I reinstalled the driver without
letting it rewrite the config file, and X with TwinView has again
started fine since then.

I'd like to do one more thing before finally declaring victory and
letting you go. (I really don't want to let my researcher go!) That is
a "dist-upgrade" to Ubuntu's Dapper Drake just released. I'll do this
by about Wednesday of next week. Then I'll try again. I suspect I'll
have to reinstall the driver yet again and it will work again with the
same config file I'm using now.

For your final response, I'd just like some good general resources on
X and the X config file. When I first ran into this problem, I posted
questions on several discussion groups and I got a wide variety of
wrong answers. If you could point me to a couple good resources that I
can study, that would help.

Thanks for your help and patience.


Request for Question Clarification by maniac-ga on 02 Jun 2006 17:53 PDT
Hello Nevada2244,

Not a problem. You now seem to be on the right track now. Let me know
next week how things work out and I'll look for some better references
to describe the overall X set up / configuration, etc.


Clarification of Question by nevada2244-ga on 06 Jun 2006 15:49 PDT
Hi maniac,

I did the dist-upgrade from Ubuntu Breezy to Dapper with no errors
reported by apt-get. It did ask me if I wanted to overwrite
/etc/gdm/gdm.conf. I replied no.

X would not start so I reinstalled the driver. The installation
appeared to go smoothly. However, X still will not start. It looks
like it is a different problem than what I had before.

The installer log file is here:
As you can see, it looks good.

The log file is here:
It's not finding the driver.

On looking around, I found this:

I might have the same problem, but it doesn't say how it was fixed. I
have no idea how the system finds its modules. "nvidia" is listed in
the file /etc/modules. In the dmesg log file it does say:

   module license 'NVIDIA' taints kernel

I'm wondering about that gdm.conf file. When looking at the directory
I did see an "XKeepsCrashing" file. I tried it and it didn't report or
change anything.

What do you think?

Request for Question Clarification by maniac-ga on 06 Jun 2006 17:28 PDT
Hello Nevada2244,

I agree that the build looks OK (I don't like all those warnings - but
there are no errors and the kernel module was built).

I agree with your assessment on the log file. On the location of
driver issue, if you haven't seen this before, please review
which indicates the locations / versions of the files for the Nvidia
install (both the kernel modules and X modules). Ensuring everything
matches the files / locations listed here should restore proper
operation. If not, I'll need to look at the X config file again to see
if anything changed from the previous copy.

> On looking around, I found this:
> I might have the same problem, but it doesn't say how it was fixed.
[see above for where Nvidia says where the files SHOULD be]

> "nvidia" is listed in the file /etc/modules.
That's the kernel module for the low level interface to the card (not
the higher level module being loaded by the X server).

> In the dmesg log file it does say:
>   module license 'NVIDIA' taints kernel
Yes - it will do that. The concept of "kernel tainting" is briefly described at
and in the kernel FAQ at
and refers to the use of non GPL modules in Linux (and the extreme
reluctance of kernel developers to debug tainted kernels). The kernel
can still work OK - and usually does - but to get help for crashes,
you have to go to the author of the kernel module that tainted the

> I'm wondering about that gdm.conf file.
That's the configuration file for the GNOME display manager (which
runs on X). We're not getting far enough to start the display manager
at this point (or if it starts - it notices that X is not running and
gives up). The "its crashing" file basically tells you what you
already know - X is not starting properly.


Clarification of Question by nevada2244-ga on 07 Jun 2006 11:59 PDT
Hello Maniac,

I checked the files from the page you cited. They were all there
except nvidia.o. Instead there was nvidia.ko and then in an nvidia
subdirectory the file nvidiafb.ko. So the files I found were:


I could NOT find nvidia.o anywhere in the file system.

I put my conf file here:

I did not let xconfig rewrite the file, so it should be the same as before.

If this doesn't give a good idea of what to do next, I'm open to doing
a fresh install of Dapper and then trying the nvidia install again
from there.


Request for Question Clarification by maniac-ga on 07 Jun 2006 17:45 PDT
Hello Nevada2224,

Hmm. I noticed you removed the old error log and configuration files.
I wanted to do a comparison but if they are not available, we may be
able to make progress without them.
[I checked my browser cache as well - they were already removed]

I noticed something that may be significant in the new log file. At
the top, it indicates
  X Protocol Version 11, Revision 0, Release 7.0
which I believe refers to X11R7 (a relatively new release). The
instructions on the NVidia site refers to X11R6 directories. Please
check your system & move the files
  /usr/X11R6/lib/modules/extensions/ ->
  /usr/X11R7/lib/modules/extensions/ ->
(or wherever the new X library files are stored - may be in
/usr/lib/xorg/modules as referenced in the log file)
and try restarting the X server.

According to the comments at
the module library moved and you should move the files to the "right" location.


Clarification of Question by nevada2244-ga on 08 Jun 2006 14:19 PDT
Hello Maniac,

I recursively copied the /usr/X11R6 directory to /usr/X11R7. Still would not start.

I saw in the log file:

   (==) ModulePath set to "/usr/lib/xorg/modules"
I copied nvidia_drv.o and there and X STARTED with
TwinView working! I rebooted a couple times and it still worked. I
restarted from full power down and it still worked.

Sorry you didn't see the old log files. I moved ISPs and just didn't
think to move those directories. Very sorry if that held you up.

I put the new log file here:
and moved my previous directory err to errs4 so the directories are in sequence.

You don't need (or want!) these, but in case you are interested these
are now on

directory: errs2 (bad conf file)
errs4 (Dapper install - could not find driver)
errs5 (working again)

If I can try to summarize what happened: With Dapper an updated
version of X was installed. X11R7 looks for a hardware driver in

But the nvidia installer still puts it in the old location /usr/X11R6.
Is this right? Does this mean everyone who uses X11R7 and an nvidia
installer will have this same problem?

I'll reboot again tomorrow and see how it goes. But we should finally
have it. Will let you go soon!

I would still like a couple of good X resources that you could recommend.


Clarification of Question by nevada2244-ga on 09 Jun 2006 07:10 PDT
Looks like the same problem here:

Request for Question Clarification by maniac-ga on 09 Jun 2006 19:43 PDT
Hello Nevada2244,

How did the tests go today?

Can we declare success at this point?

If so, I can post a proper answer with the overview of the solution as
well as the additional X references / materials.

If not, please let me know what still needs to be fixed and I can do
some more research solving this problem.


Clarification of Question by nevada2244-ga on 10 Jun 2006 10:45 PDT
Hello Maniac,

Yes, we're successfully done. Thanks for your patience and expertise.

I learned a lot and look forward to your wrap up.

Will gladly try Google Answers again.

Subject: Re: Troubleshooting Nvidia TwinView on Ubuntu Linux
Answered By: maniac-ga on 11 Jun 2006 15:18 PDT
Rated:5 out of 5 stars
Hello Nevada2224,

I am glad that it has worked out so far. Let me summarize the problems
and current solution and then provide some further resources on the X
window system.

The initial problem was a failure to start the X server. The symptom
was messages in the log file that appeared to run OK until the
following messages appeared:

Fatal server error:
Caught signal 11.  Server aborting

After some initial diagnosis, we determined that the 3D acceleration,
otherwise known as "GLX" was causing the problem. GLX is described at
and several other sites - search for
  glx (or xgl) x windows
to find more resources
Disabling this was the initial fix for your system.

When you upgraded your system from "breezy" to "dapper", that update
introduced a newer version of the X server which broke the X server in
a different manner. In this case, the update relocated only SOME of
the files necessary to run the X server. We resolved that by moving
the nvidia module / driver files to
and restarting the server.

At this point, your display works "OK", though there may be some
additional changes needed to fully enable the 3D acceleration (GLX).
Make a clarification request if you want to follow up on this or
continue to use the system as is.

Additional references on the X window system and how it works follows:

[1] A general overview of the system, historical descriptions, and a
number of links at

[2] Another high level overview with some specifics to Linux

[3] Another high level description of the X window system
Some of the more detailed pages include nice illustrations comparing
the displays with no window manager, a minimal window manager, and

[4] A single page describing the architecture (with some nice
diagrams) of the X window system

[5] A section out of "The Art of Unix Usability" by Eric Raymond is on line at
which describes some of the characteristics of the X window system,
primarily from a user's perspective. The main document indexed at
has a lot of related material you may find interesting as well.

[6] If you wonder why applications don't seem to respond as you expect
- an example at
describes the different methods "Cut" and "Paste" are implemented by
an X window client (application). Its somewhat unfortunate that X has
more than one way to implement some capabilities, and not all
applications implement them properly.

[7] A generally sarcastic view of the X window system is at
which is a chapter of the "Unix Haters Handbook" by Garfinkel, Heise,
and Strassmann.

[8] As an alternative to the method you used to install the Nvidia
drivers, your distribution has a "How To" at
for the Nvidia drivers. You may wish to change to this method so
others debug the installation (e.g., the difference between X11
version 6 and 7) and get everything set up properly.

[9] The main site at
Primarily of interest to those preparing distributions such as Ubuntu.
There is a bug list and mailing lists. I suggest you review the
mailing list archives prior to signing up to a mailing list to make
sure the discussion has the kind of information you are looking for.
However, there is documentation embedded in the distribution as
described at
which describes how to get a copy of the documentation (for viewing or printing).

[10] O'Reilly sells a comprehensive series of books on the X window
system. For example
is a programming manual for Xlib (the lowest level of X programming).
Other volumes in the series describe network messages, higher level
packages (e.g., Motif), and related materials.

[11] Searching with a phrase such as
  x window linux faq
brings up sites such as
which has a variety of answers to "Frequently Asked Questions" related
to the X window system or
which has a huge list of links organized in broad categories.

I hope you find these resources helpful in your further work with your
systems. Please make a clarification request if this list is
incomplete or unclear. Good luck.

nevada2244-ga rated this answer:5 out of 5 stars and gave an additional tip of: $25.00

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy