Google Answers Logo
View Question
Q: windows XP pro: drive-letter assignment when plugging a USB device broken ( No Answer,   0 Comments )
Subject: windows XP pro: drive-letter assignment when plugging a USB device broken
Category: Computers > Operating Systems
Asked by: tormen-ga
List Price: $50.00
Posted: 28 May 2006 09:59 PDT
Expires: 11 Jun 2006 15:36 PDT
Question ID: 733055

My Windows XP prof. SP2 incl. all updates is not able to assign/remove
drive letters from USB drives anymore.

I think, I need to know and check all prerequesits to "automatic
driver letter assignment" within windows xp professional
(especially when you plug an USB device):
	what SERVICES need to be started for SURE?
	what hives within the REGISTRY take part in this process?
	what ELSE is involved?

If someone can tell me this and I can check these points and I can
solve my problem like this,
it would be worth up to 150$ for me (and so I would PAY them actually :-) !

If someone has "only" a TOOL that can FIX my computer so that it works
fine again (according to this USB problem)
If someone just tells me straightaway one LITTLE thing to fix and then
it works again
then it would be worth only the 50$.

I hope this is fair.

If you are ABLE to help me, please contact me anyway, because I NEED
to solve this problem WITHOUT complete REINSTALLATION.
If someone would know the 150$ solution, I would either increase the
question-price (if possible) OR I would create a new question with
this price!

So I hope someone is able to tell me WHY this does not work anymore...
and WHAT exactly is necessary to make it work again :-)

Thnx a lot for any try, any hint in advance.




What follows is a DETAILED step by step description of TWO devices I tried:
	the FIRST one - my digital-camera - I plugged for the FIRST time
after a windows repair-installation
	the SECOND device - my USB-Stick - I had already connected to my computer before

Be aware, that within this part I tried to translate parts of the
windows output from german to english.

//// FIRST EXAMPLE /////

So something seems broken - maybe within the registry or service-configuration?!
But I don't know how to debug this problem systematically.
I am an experienced computer user and able to use regmon if I know
what to search/look for and which filters to use.

So I am searching a person that can help me to find the reason for
this misbehaviour of my windows xp installation. I would like to learn
during this process how to deal with such problems.

About the problem:

What I will describe next is the behaviour at the moment - AFTER I
just freshly did a windows-xp repair-installation (booting from the
windows xp prof. cd).
But I had the same behaviour already before.

As a USER (group member: "user" ONLY):
If I plug a new USB device (the whole example is about my camera which
I connect via USB cable with the computer - it was the FIRST connect
after the repair-reinstall of windows xp prof.), the USB device is
recognized and
within the device manager it gets installed under "drives" (in this
case "FUJIFILM USB-DRIVEUNIT USB Device") additionally a
"usb-massstorage" device appears under the USB hive.
The found new hardware and got installed and is ready to use
information popup appears within the systray.
At the same time the "remove hardware" icon appears within the systray.
If I single-left-click on it, I get: "remove usb-mass-storage device",
so NO drive letter!

Then I logged off and on again as "Administrator".
I replugged the device... no drive letter.
I started the computer administration mmc and opened the diskpart plugin.
There I SAW the new device (my fujifilm camera).
I assigened a drive letter to the device (K, like german Kamera).
I started a new instance of the windows-explorer: But NO drive K.
I logged of and on as USER again:
I had the drive K and could work with it.

I repluged the device (turned the camera OFF and ON again):
Drive K was still visible within the windows explorer, but if I try to
access it, I get an error message from windows titled "Working place"
which says:

"K:\ refers to an invalid path, which is not available at the moment.
It may be a harddrive or network drive. Please assure that the media
is inserted correctly, or that the internet connection is up and
running and repeat the process. It may be that the information was
moved into another place, if the path stays invalid."


So I start the diskpart mmc plugin again and... the usb-device of my
camera is there but has (again) NO drive-letter?!

If without changing at this point I call "mountvol" under cmd.exe, I get:




Starting the "diskpart" under cmd.exe and "list volume" I get:

DISKPART> list volume

  Volume      Bst  Bezeichnung  DS     Typ         Größe    Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0                             DVD             0 B
  Volume 1     C   SYSTEM       NTFS   Partition     20 GB  OK         System
  Volume 2     D   WIN-DATA     FAT32  Partition     15 GB  OK
  Volume 3                      FAT    Wechselmed  1000 MB

So the usb-camera-device (= Volume 3) is without drive letter.
Drive letter K is not available (as I saw within the diskpart gui mmc).
I could now reassign another letter and repeat the game... but this is
not useful to me as after replugging the device once the drive letter
will remain as a zombie drive letter and the device will be again


The same like above happens, if I use my only usb-stick (Sandisk Titanium Cruzer):
It is recognized when I plug it, but does also get NO drive letter assigned.
Here is what happens after I plugged the USB-Stick as ADMINISTRATOR
and then called diskpart on console window:
(sorry for the parts in german)


Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Dokumente und Einstellungen\Administrator>diskpart

Microsoft DiskPart Version 5.1.3565

Copyright (C) 1999-2003 Microsoft Corporation.
Auf Computer: KRUEMEL

DISKPART> list volume

  Volume      Bst  Bezeichnung  DS     Typ         Größe    Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0                             DVD             0 B
  Volume 1     C   SYSTEM       NTFS   Partition     20 GB  OK         System
  Volume 2     D   WIN-DATA     FAT32  Partition     15 GB  OK
  Volume 3         USB-STICK    FAT    Wechselmed   495 MB

DISKPART> select volume 3

Volume 3 ist das derzeit gewählte Volume.

DISKPART> assign letter=U

Der Laufwerkbuchstabe oder der Bereitstellungspunkt wurde zugewiesen.

DISKPART> list volume

  Volume      Bst  Bezeichnung  DS     Typ         Größe    Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0                             DVD             0 B
  Volume 1     C   SYSTEM       NTFS   Partition     20 GB  OK         System
  Volume 2     D   WIN-DATA     FAT32  Partition     15 GB  OK
* Volume 3     U   USB-STICK    FAT    Wechselmed   495 MB


Datenträgerpartitionierung wird beendet...

C:\Dokumente und Einstellungen\Administrator>


	dir u:\ works
	BUT the windows explorer does NOT show u:\
	and mountvol does NOT show something about the USB-STICK at all

I log off and log on as Administrator:

I have U:\ as "USB-STICK" within the windows explorer.

But if I click on the "remove hardware" systray-icon I only get:
	"USB mass storage drive" so WITHOUT A drive letter and without
"Cruzer Titanium" like it identifies itself within the devie manager

I then clicked on it to REMOVE the device. Windows answered
successfully removed the device.

As I then pressed "F5" to reload within the windows-explorer, the
drive U: STAYED, also restarting a new instance of the
windows-explorer would NOT change this. Only the description/name had
changed from "USB-STICK (U:)" to "Local Drive (U:)" (Lokaler

And to replug the USB-Stick would leave me in the same situation as
before with my USB-Camera: again NO accessible drive within
windows-explorer, more over this "DEAD" drive letter U: ...

Request for Question Clarification by hummer-ga on 30 May 2006 08:23 PDT
Hi tormen,

There is an excellent discussion at the following forum which just may
help you (highlights below).

Title: USB Flash drive not listed in My Computer despite visibility in
computer management

Comment from sirbounty
Date: 03/30/2006 03:58AM PST
sgorshow - first of all, I just want to elaborate what has already been mentioned.
Click Start->Run->MSConfig <Enter>
From MSConfig's Services tab, check the box at the bottom to hide all
MS services.  Then click Disable All.
From the Startup tab, click Disable All.
Now reboot and see if you have any different results.

This method is good for eliminating a conflicting process and can lead
us further in the direction of 'is it hardware or software'?

Additionally, have you tried this in another system?

MSConfig will open automatically after the reboot.  Don't change
anything before you check the drive.
If all is as before, just select Normal Startup from MSConfig and
reboot to put everything back the way it was.

If the symptoms are the same in the limited startup, try this routine
to completely remove any PnP drivers for the USB storage device:

Click Start->Run->CMD <Enter>

Type the following lines precisely as a typographical error will not
produce an error message (CAPS for emphasis only):

Start Devmgmt.msc <Enter>

From the Device Manager console that opens, choose View/Show Hidden devices.
Now go down to your USB section, expand it, and see if you can locate
any 'ghost' icons.  These would be drivers that are installed, but not
presently in use.  You want to focus on these, if any are found, and
remove them (uninstall), along with any USB Mass Storage Device items
(that should be the list item for the flash drive).
Additionally, you'll want to look under the Disk Drives section for
any presence there as well.

Now reboot and remove the drive before Windows loads.  

Next, let's perform the following, just to be sure...

Start->Run->CMD <Enter>


Check these two generated files for any drive assignments, then go
into disk manager (Start->Run->Diskmgmt.msc) and verify the drive
assignments there as well.  Maximize the window and look at both the
volume list at the top and the graphical view at the bottom.  Note any
other drive assignments than the ones you've implied previously (C &
Now click View/Drive Paths to determine if there are any other mount
points.  If not, proceed by inserting the flash drive.
Watch device manager to see what drive letter it assigns.  Verify that
you can connect to it, by right-clicking the newly creating drive
assignment and click open/explore.  You may even want to manually
assign it a higher letter, like H.

If the above works and you 'still' can't access the drive from my
computer, post back, as I have a few other ideas that we can try. 
Good luck!
Comment from sirbounty
Date: 04/05/2006 08:00AM PDT

So, there's no C:\Maps.txt or C:\Subst.txt?
The files should at least exist, even if they're blank...
Comment from sirbounty
Date: 04/05/2006 08:09AM PDT

One other thing to try here please...log in with a different user -
create a new account if you must...
Then insert the drive and determine if you can see it in My Computer?

You said:
"it is a laptop and it is connected to my company's internal network
with 2 network drives mapped"

Are you certain there aren't any policies 'hiding' this drive?

Click Start->Run->rsop.msc <Enter>

It'll take a bit and eventually display 'active' policies.  The one(s)
you'll be looking for (the needle in the haystack, so to speak), would
be under User Configuration\Admin Templates\Windows Components\Windows

Look through those and see if it's simply a group policy causing you
this aggrivation...
Comment from sirbounty
Date: 04/05/2006 08:18AM PDT

Oh, but you did get it located under Z, so the policy shouldn't apply.
Try this instead:

Start->Run->cmd /k reg query
(You can copy everything after Run-> into your Run's Open box and hit
<Enter>.  It will leave the window open with the results).

Then repeat it with a slight modification:
Start->Run->cmd /k reg query

Post the results of these two queries.
Bingo...we've found it.
You have a policy being pushed that's causing this.
Accepted Answer from sirbounty
Date: 04/05/2006 09:15AM PDT
Grade: A
Accepted Answer 	

The hex value of 33FFFE03 seems to equate an invalid assignment (if
you were interested in that tidbit at all).

Thus, the following should resolve this for you:

Start->Run->cmd /k reg delete
hkcu\software\microsoft\windows\currentversion\policies\explorer /v
NoDrives /F

May require a reboot afterwards - just ensure that command comes back "successful".

Hope that helps!

Clarification of Question by tormen-ga on 31 May 2006 07:37 PDT

Thnx for your answer. Here are the results:

Within limited startup I removed all hidden (ghost) drives and usb devices.
I restarted.
I looked within maps.txt, subst.txt (both empty).
I looked for further mount-points: none.
I plugged the USB-Stick (which works on other computers fine).
I selected "refresh" from the view "actions".
The diskmgmt.msc hung for several seconds ... (quiet LONG about 1-2
minutes!) and then came back with: USB-STICK (FAT), but WITHOUT
automatic drive-letter assignment!
(as I described in my question).

about "active" policies: with the rsop.msc under
	"User Configuration" I only have "Software Settings" and "Windows
Settings", no "Admin Templates".

I created a second user account "admin" belonging to the administrators group.
I tried with it: And no change.

Here are the results from the two reg query calls:
C:\Dokumente und Einstellungen\Administrator>reg query hkcu\software\microsoft\w


    NoDriveTypeAutoRun  REG_DWORD       0x9d
    ExSearchOptions     REG_DWORD       0x196b1
    NoDrives    REG_BINARY      00000000
    NoActiveDesktop     REG_BINARY      01000000
    NoSaveSettings      REG_BINARY      00000000
    ClearRecentDocsOnExit       REG_BINARY      00000000

C:\Dokumente und Einstellungen\Administrator>reg query hklm\software\microsoft\w

Fehler: Der angegebene Registrierungsschlüssel oder Wert konnte nicht gefunden w

C:\Dokumente und Einstellungen\Administrator>

Nevertheless I tried:
C:\Dokumente und Einstellungen\Administrator>reg delete hkcu\software\microsoft\
windows\currentversion\policies\explorer /v NoDrives /F

Der Vorgang wurde erfolgreich ausgeführt.

I removed the devices of my USB-STICK from the device-manager, I
plugged the USB-STICK --> no change.
Again it took the diskmgmt.msc around 1-2 minutes to UPDATE after I
plugged, no drive letter was mentioned in the "remove
hardware"-systray-icon info. There it only said (still): remove
USB-mass-storage-device (so WITHOUT name and drive).

But maybe this long update in the diskmgmt.msc is because I am still
in "limited startup" (configured via msconfig following the
instructions you sent me).

Any new/further ideas?

What is the reason that the USB device gets NO drive letter assigned automatically?

What about my question what services are necessary to be started for this to work?



Request for Question Clarification by hummer-ga on 31 May 2006 10:15 PDT
Hi tormen,

Regarding Services, Elder Geek has done a top-notch job in explaining
each one. Read the following page and then click on each service link
to view a table which contains this info:

 Service Name - 
 Process Name - 
 Default Settings - 
 Microsoft Service Description - 
 Dependencies - 
 Real World Description - 
 Is This Service Needed? - 
 Recommended Setting - 
 Note - 

Services Guide for Windows XP

Thank you for posting the list of your results, I'm looking through
them. It seems the problem you are having is not uncommon, but
unfortunately the cause/solution varies. I'll see if I can come up
with anything else for you -

Request for Question Clarification by hummer-ga on 31 May 2006 12:42 PDT
Hi tormen,

Well, it's been an interesting read but I'm afraid nothing definitive
- the solution seems to be in using a trial and error approach.
Following is another good thread, I've copied some key points (but
read the thread for full details).  Good luck, hummer

Title: XP Pro will not recognize USB mass storage devices

In order to remove the residual files do the following:
1. Open installed components in Device Manager, go to "Driver" and
there click on "Driver details"
2. Write down the files names and their paths.
3. Uninstall the device in Device Manager.
4. Go and delete those files.

You may also look for the names of those files in \WINDOWS\INF dir to
delete those and in registry and remove those keys.
I have had this happen  and have always solved the problem by removing
all USB drivers from Device Manager, rebooting and letting them

1. Go into Device Manager and expand the "Universal Serial Bus Controllers" group.
2. Uninstall every device listed under this group (right click on
device, left click uninstall)
3. Be sure all USB devices are unplugged!! *THIS IS KEY*
4. Restart Computer
5. Upon restart the computer will recognize all the devices and install them.
6. Plug in a device and see if it works.

OK, I did it - a clean install. Everything is working fine now - the
Sony camera, Sandisk reader (with 4 drives) and my flash card. Letting
everything go to the default letters, the drives ended up assigned to:

C,D,E,F  Harddrives
G,H        CD and DVD
I          Camera
J,K,L,O    Sandisk
Q          Flash card

I was surprised to see that the Sandisk skipped over M,N and the Flash
card skipped P. I bet that the earlier problem and these assignments
are related in some subtle way.
I plugged them in one after another (camera-Sandisk-Flash), each time
leaving the preceeding ones plugged in and powered on. That made sure
they didn't accidentally try to pick the same letter.
Step 1: Remove Hidden Devices

1. Click Start. Click Run. Type cmd and press OK.
2. Type "set DEVMGR_SHOW_DETAILS=1" (without quotation marks) and press Enter.
3. Type "set DEVMGR_SHOW_NONPRESENT_DEVICES=1" (without quotation
marks) and Press Enter.
4. Type "start devmgmt.msc" (without quotation marks) and click press Enter.
5. Click View. Click Show hidden devices.
6. Click "+" to expand Imaging devices, Unknown devices and USB devices.
7. Are there any digital camera devices and unknown devices (including
grayed out devices)? If so, please right click it and click Uninstall.

Step 2: Remove all oem*.inf files


1. Click start and click run then under the run line type in the
command "cmd" (without the quotation marks)

2. In the command line, type in the following (without the quotes) and
press enter after each command:

"cd \windows\inf"
"ren infcache.1 *.old"
"ren oem*.inf *.old"
"del C:\windows\setupapi.log"

Step 3: Removing all entries under HKEY_LOCAL_MACHINE/Enum/USB that start with VID


Removing the VID entries from the registry will cause them to be
redetected at restart.

CAUTION: If you have a USB keyboard or mouse, do not remove the VID
entry for these devices, otherwise, Windows may not restart correctly.

1. Click Start and click Run. Type regedit and click OK. The Registry
Editor window will open.

2. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\USB.

3. Highlight and delete all the VID_.... entries.

Permissions may be set allowing the deletion of the VID_ entries by
following the steps below:

a) Right-click the key to be deleted, and then click Permissions. The
VID_... Permissions window will open.
b) With Everyone highlighted in the Group or User name section, select
Full Control in the Permissions section.
c) Click Apply, and then click OK.

4. Turn off the computer.

Step 4: Reconnect the digital camera to the computer system:


1. With the computer system turned off, reconnect the Sony DSC-P50
camera to the USB port.
2. Restart the computer.
3. After the Windows operating system has finished restarting, plug
the digital camera into the electrical outlet.
4. A New Hardware Detected window should open and reload the drivers.

If the camera still cannot work, I recommend you plug the camera to
another Windows XP computer (Desktop) to test whether this camera
works. I suspect it is an incompatibility issue.

Microsoft Windows Support Professional
One time I discovered that even though Explorer didn't show the
drives, I typed the drive letter into the address bar and it then
showed it (ie, H:\ ). I was actually quite surprised when it did that.
ok, i went out and bought a PCI USB 2.0 card for like $15, its got
three ports, and everything works now...
my guess is its something to do with intel's usb 2.0 chipset being... well... 
do yourself a favour, go to your local computer store, and just get a
usb 2.0 card, its soooooooooooo much easier than screwing around with
everything... it took me nearly 2 days of searching google for a fix,
messing with xp installs, trying to install drivers in a certain
$15, and all your problems are fixed.
In Windows Explorer, right-click your hard-disk, and then click Properties.
Click the Hardware tab.
Click the hard disk, and then click Properties.
Click the Policies tab.
Click to clear the Enable write caching on the disk check box, and
then click OK two times.
Press CTRL-ALT-DEL to bring up a task list.

You can end task on one program at a time, trying to stop the device in between.
Do not end task on Systray or Explorer. This will cause Windows to crash.
It turns out....that I had drive letters A thru F asigned to local
resources.  My first NETWORK drive started at G. As luck would have
it, the G Mapped drive no longer existed, but was still viewed as
"Accounting on server-name"..When I clicked on it, Violia!  there was
my PC Camera. WinDOZE took the G mapping as it wasnt used, and didnt
BOTHER to let me know :-)  ( Idid repeatedly press refresh..tothe
point, my F5 key needs replacing!)
This fixed the issue "The specified service does not exist as an
installed service" error for USB storage devices

967-E325-11CE-BFC1-08002BE10318} key in the registry, where I
discovered a zero-length binary "LowerFilters" value (which should be
string or multi-string).

It should not exist with zero-length let alone be binary.

Delete this value and then reboot.
Go to Control Panel/Computer Management/Storage/Disk Management.
I saw my drive but it didn't have a partition or drive letter, so did
a quick format, nominated a partition and gave it a drive letter.

Clarification of Question by tormen-ga on 03 Jun 2006 03:20 PDT

Wow... a lot to try :-) This will take some time.

Was of not much help. I did rather learn something new. Moreover I
think it is not correct what is written in there, because I have a
desktop computer (and many other comuters), where I DISABLED the TWO
disk volume manager services and everything works fine!

So this service is NOT essencially needed as noted on this page!

I hate that Micosofts interna are so rarely documented.

Thats why I asked for services that are especially *neccessary* for my
USB-Stick to be recognized and having a driver letter assigned.



Clarification of Question by tormen-ga on 03 Jun 2006 03:21 PDT

"and everything works fine!" means: I plug a whatever NEW USB-Device
and it is handled properly (recognition/drive-letter-assignment/usage)
works fine.


Clarification of Question by tormen-ga on 11 Jun 2006 15:36 PDT
It is a too difficult matter. And to continue with trial error is no
solution for me. Then it is no difference (in time/effort) for me to
completly reinstall the system.
Thats why I gave up.
Thnx so far.

There is no answer at this time.

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy