Google Answers Logo
View Question
Q: OSX Internet Sharing - WEP Problems ( No Answer,   0 Comments )
Subject: OSX Internet Sharing - WEP Problems
Category: Computers > Security
Asked by: lithiump4-ga
List Price: $10.00
Posted: 25 Oct 2006 21:08 PDT
Expires: 06 Nov 2006 13:32 PST
Question ID: 776986
I am using Internet Sharing in OSX 10.4.8 to share my cable modem to
other PC's wirelessly.  It works fine when I leave the network
unsecured, but when I enable either WEP 40-bit (aka 64-bit) or
128-bit, nobody can connect to the network.  I want to either be able
to enable encryption or MAC Address filtering to prevent unauthorized
computers from accessing the network.  Thanks for your time.

Request for Question Clarification by aht-ga on 25 Oct 2006 22:13 PDT

A couple of questions for you...

Are the other computers that you are sharing your connection to, Macs
or Windows-based PCs? There is a difference in how OSX and
Windows-based systems handle WEP keys, and is the cause of much
frustration in mixed computing environments.

Also, have you given any thought to just acquiring a wireless router
to free yourself from having to manage this through Internet Sharing,
and having all the other computers dependent on your Mac being on and


Google Answers Researcher

Clarification of Question by lithiump4-ga on 30 Oct 2006 05:22 PST
The computers that are connecting are Windows-based PCs.  We have
multiple routers, but none seem to work well with P2P sharing
programs.  (Routers are known to crumble under the strains of
torrents.  We have to reset the router at least once a day because the
internet just stops working.)  I have tried this with 4 different
routers with the same effects.

Internet Sharing in OSX proves to be a much better router than any of
our hardware firewalls.

I hope this helps you.  I'm sorry it took so long to respond (I never
got an email stating I got a Request for Clarification)

By the way, I have also tried using a WEP key generator to no avail.


Request for Question Clarification by aht-ga on 30 Oct 2006 23:37 PST

There have been problems with the e-mail notification system, which is
why you did not receive a notice; hopefully you are able to check back
periodically to see if there have been any updates to your questions.

I will continue using the Request for Question Clarification to find
out more about your problem and to suggest things for you to try, in
case I am not able to solve your problem completely. Only after we
have found the solution, will I post it as the answer.

Can you please tell me exactly how you have been setting the WEP key
in both your Mac and the Windows-based PCs? Are you using a
hexadecimal number, or are you using a passphrase? The best way to set
up WEP in a mixed environment like this, is to use a hexadecimal
number in all machines. This is due to a difference in the algorithm
used by most Windows WiFi clients (including XP's client) and the
AirPort Options utility to convert a passphrase into a hex key. When
you enter the hex key directly into the AirPort Options, though, you
MUST prefix it with the dollar sign ($) so that OSX knows that it is a
hexadecimal number. Not doing this is the number one cause of WEP key
incompatibility in mixed Mac/Windows environments!

Please refer to this Apple technical note to learn more about this:

Is this how you have been entering the WEP key already?

Clarification of Question by lithiump4-ga on 01 Nov 2006 09:50 PST
I entered a 64-bit hexadecimal number preceded with the "$" sign, for
instance "$363b6e3c6f" (without the quotes) on the Apple (server)
side, and "363b6e3c6f" on the PC (client) side.  I also tried 128-bit
numbers and got the same result.

This is one of the WEP key generators I have tried:

Request for Question Clarification by aht-ga on 01 Nov 2006 20:05 PST

Are you by any chance using a Mac with an Airport Extreme WiFi
adapter, and are the Windows machines indeed running XP? If so, then
unfortunately at this time it seems that the general concensus on the
Apple Support Forums is that WEP cannot be used with the built-in
Internet sharing utility:

However, there is the odd case where someone is actually successful:

So, before giving up, try setting the WEP key again, then reboot the
Mac. If that doesn't work, then there may be no solution until Apple
chooses to roll out an update.


Google Answers Researcher

Request for Question Clarification by aht-ga on 05 Nov 2006 00:52 PST

Given that we were able to resolve the related issue you had with
enabling MAC address filtering, do you still wish to pursue a solution
to this problem with setting WEP on your ad hoc network? If not, you
can expire the question in order to close it.


Google Answers Researcher
There is no answer at this time.

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy