Google Answers Logo
View Question
Q: Intellisync for Yahoo! fails with "memory cannot be read" or "written" error ( Answered 2 out of 5 stars,   0 Comments )
Subject: Intellisync for Yahoo! fails with "memory cannot be read" or "written" error
Category: Computers > Software
Asked by: medic037-ga
List Price: $50.00
Posted: 20 Nov 2006 18:24 PST
Expires: 20 Dec 2006 18:24 PST
Question ID: 784401
Using lastest version of Intellisync for Yahoo! (is4yahoo.exe) with
Outlook 2003 on a Windows XP Pro, SP2, 500MB RAM, Intel Pentium M
processor, Tablet PC Gateway laptop. Use to be able to sync between
Yahoo and Outlook with Intellisync for Yahoo! then something happened
one day (??) and since then I cannot get past the following error when
I try to run Intellisync:

The instruction at "0x003735c6" referenced memory at "0x0023a000". The
memory could not be "written".

Click on OK to terminate the program
Click on CANCEL to debug the program.

If I click OK, I then get:

The Instruction at "0x7c910de3" referenced memory at "0xfffffff8". The
memory could not be "read"

Click on OK to terminate the program

...which it does.

Nothing I have tryed has worked. I have uninstalled, reinstalled, ran
spyware, ran registry cleaners, repaired Outlook, update Windows,
poked at Voodoo dolls...more. And of course Yahoo! won't support the
program besides the FAQ which is useless. I have seen other references
to the problem by Google searches but none with an answer. If it
worked OK before, what could cause it to stop working suddenly and how
can I fix the problem.

Any help would be GREATLY appreciated!
Thanks in advance.
Subject: Re: Intellisync for Yahoo! fails with "memory cannot be read" or "written" error
Answered By: sublime1-ga on 20 Nov 2006 23:03 PST
Rated:2 out of 5 stars

There are several possibilities as far as resolving this problem.
Essentially the message is saying that some other process has the
memory at those locations locked, thus making them unreadable, or
unreadable, and interfering with Intellisync's processes.

This possiblity is discussed in this post on Experts Exchange, by
sunray_2000, in the Accepted Answer:

"This is not an Access [or, program-specific] instruction that the
 message refers to, this is a low level memory read error from windows.

 If this is happening predictably it could be:
  1. a bad memory module.
  2. A conflict with another dll or ocx control trying to compete
     for the same memory area."
"If you have Dr Watson running and trapping errors, you can gain
 some additional insight into what is happening at the 'moment of

If you need to know more about running Dr Watson, let me know.

For the sake of covering all possibilities, is Intellisync a
java-based program, and are you using Microsoft's Java Virtual
Machine? If you are still using Microsoft's I would recommend
uninstalling it and using the Sun machine, and seeing if that
makes a difference:

Another way to isolate the program (if that's what it is) which
is causing the conflict with Intellisync is the following:

Go to Start -> Run -> Type in 'msconfig' and press 'Enter'
Go to the Startup tab.
Disable all the applications there except anti-virus.
Reboot the machine and check if the issue continues.
If not, then enable one at a time in the same Startup
tab and find the application or process that might be
causing the conflict.

There's actually a freeware program called WinPatrol
which provides an easier way to temporarily disable
Startup programs, called WinPatrol. That, and many
other freeware solutions for Windows security, can
be found on this previous question I answered. You
say you've run anti-spyware software, but in this
answer, you'll probably find some options you have
not considered, which might find something that's
escaped your notice so far:

Yet another possibility is that a Windows file has
become corrupted. There are two ways to fix this.
One is to use the System File Checker tool to scan
all the protected files on your computer:
Click Start, and then click Run.
In the Open box, type: sfc /scannow and then click OK. 
You may be prompted for the Windows installation CD.

It's also possible that the conflict is being caused
by a program you installed just before you noticed
Intellisync returning the error messages. Microsoft
has an article on how to use System Restore here:

Finally, it's quite possible that you have a bad stick
of RAM. You could try re-seating them, removing them one
at a time, or having them tested professionally. Since
memory in RAM is sometimes passed on to Virtual Memory
on your hard drive, you should also verify that your
Virtual Memory is set to about 2.5 times the size of
your RAM, or 1280MB. If you need to know where and how
to check that, please ask. It's also possible that the
hard drive itself is failing, and the program is having 
trouble accessing an address of virtual memory because
of it.

You can also test your RAM using a program such as
Memtest86, a freeware memory tester:

Memtest86 can run for a very long time, so I'd try
pulling one stick at a time first.

Due to the ambiguous nature of trying to fix a computer
problem at a distance, especially one which may have more
than one cause, it's quite possible that nothing we try
will work, but a search for this problem specific to 
Intellisync turned up no results at all.

Please post a Request for Clarification if you have any
questions, or something is unclear...


Additional information may be found from an exploration of
the links resulting from the Google searches outlined below.

Searches done, via Google:

"The instruction at * referenced memory at * . The memory could not be written"

"The instruction at * referenced memory at * . The memory could not be
written" "could not be read"

intellisync "The instruction at * referenced memory at * . The memory
could not be written"

is4yahoo.exe "The instruction at * referenced memory at * . The memory
could not be written"

Request for Answer Clarification by medic037-ga on 22 Nov 2006 14:34 PST
Thanks for the attempt, but no joy. The problem could not be real or
virtual memory as it happens on three different PC's. Dr. Watson does
not record any crash data. (I made sure it was the error analyser with
[drwtsn32 -i] and set the auto=0 so I could see when the error
occured. (I'll take any suggestions on that) I tried disabling all
startups with msconfig, no luck. It crashes the same way on another PC
syncing to a Mobile PC (not Outlook), so it seems as if the target app
has no bearing on the error. It's not a Java app. Virtual Mem is 3x

It use to work, and that lead me to believe that something has
clobbered something somehow. (how's that for tech-talk?)

Any other suggestions?  Can Dr. Watson be made to capture the crash? 


Clarification of Answer by sublime1-ga on 22 Nov 2006 15:48 PST

Before running Dr Watson again, I wonder if you can see any 
useful error messages by r-clicking on My Computer and clicking
"Manage", and then looking under Event Viewer -> System and/or
Application sections.

As far as Dr Watson, I found this post on the Shareza forum about
making it work properly under Windows XP:

"In order for Dr Watson to work correctly, you might need to
 disable Windows Error Reporting:

- Open System in Control Panel (click Start, click Control Panel,
  and then double-click System).
- On the Advanced tab, click Error Reporting.
- Then disable the Programs checkbox to disable it for all programs 


- Select Enable error reporting, and then click Choose Programs.
- Under Do not report errors for these programs, click Add.
- Type the program's executable name, being [is4yahoo.exe]"

While this failure across 3 computers strongly suggests a bug
in the program itself, you didn't mention whether you tried a
system restore on the chance that a recently-installed program
might have installed a file which is locking the memory (or as
you so eloquently put it, "something has clobbered something").

Apparently there are a LOT of users who have found the program
unworkable in many ways. One user on this thread from the 
HandheldNews forum concludes:

"I suggest NO ONE use Intellsync and Yahoo to sync - too many
 problems, no support."

The rest of the thread may prove informative, as well:

Many users on this thread from (and other threads
I've found) report that Intellisync seems to have problems
especially with Windows XP. Reading through the thread may
give you some ideas. One post suggests using an older version:

"I noticed that my older version of Intellisync I had at
 home kept working whilst the newer one at work didn't.
 I tried installing the older one at work and that works
 fine now. BAD conflicts first time using it though. I get
 a popup box telling me there is a newer version every time
 I open it, but it seems to work fine."

Let me know where this takes you...


Searches done, via Google:

"intellisync for yahoo" "windows xp" errors OR crashes OR problems

Request for Answer Clarification by medic037-ga on 09 Dec 2006 15:54 PST

Just as a follow-up, nothing worked. I can duplicate the problem on
two different computers. Another friend of mine has it working fine on
his computer.

I'm very distressed at Yahoo! and Nokia for not supporting the product at all. 

My work around for the time being is to pull Yahoo! calander data over
manually and import into Outlook by Outlook's import wizard. I don't
have a longterm solution. If Google had the same functionality as
Yahoo! I would switch in a hearbeat... maybe someday.

Thanks for taking a stab at this, you worked hard enough for me not to
request the money back from Google; however, I'll have to rate the
answer appropriately.

Thanks again, and happy holidays!

Clarification of Answer by sublime1-ga on 11 Dec 2006 21:17 PST

Sorry things didn't work out. I hadn't given up on continuing
to help you, so I'm sorry you finalized the question by rating
it. Best wishes for your holidays!

medic037-ga rated this answer:2 out of 5 stars
The answer did not help, so in essence the answer was wrong. The
researcher did however discover possibilities that I did not find or
try before I posted the question, so his efforts are appreciated.

There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy