Google Answers Logo
View Question
Q: easy cd creator 5 is reading my cd-rom and my cd-rw as the same drive. ( Answered,   0 Comments )
Subject: easy cd creator 5 is reading my cd-rom and my cd-rw as the same drive.
Category: Computers > Software
Asked by: walsh153-ga
List Price: $10.00
Posted: 23 Oct 2002 18:41 PDT
Expires: 22 Nov 2002 17:41 PST
Question ID: 89047
I am using Windows 2000 pro,I've never had any trouble burning
cd's,until now.I'm using easy cd creator 5(platinum).When I put in a
cd in the cd-rom and select it as the source,it shows it as drive E,it
also shows all the tracks.Then when I put a blank cd in the cd-rw
drive(D)it shows it as drive E
and then says there is no room on the cd.In windows explorer if I
right click on drive E and select properties it shows E as the
cd-rw.When I right click on drive D it shows it as the cd-rom .
I tried uninstalling easy cd creator 5,and reinstalling it but the
same thing happened.
When I was using windows 98 last year my cd-rom was drive E and my
cd-rw was drive D,but ever since I put in 2000 it has been the
I need to get the cd-rom and the cd-rw to show up as separate drives,consistently.

Request for Question Clarification by pwizard-ga on 23 Oct 2002 19:05 PDT
Did you upgrade Windows 98 to Windows 2000 Pro or did you do a fresh
install? Have you applied any of the software updates to Easy CD
Creator 5 available from Roxio's website?

You say this was working before... same environment? Same software?
Did anything change?

Clarification of Question by walsh153-ga on 23 Oct 2002 20:47 PDT
I upgraded to win 2000,from Win 98.When I was using cd creator 5
before the problem started I had the updated version,but at this time
I haven't updated the software yet.
But when I switched from 98 to 2000 I intended to do a clean install.I
reformatted the hard drive and started fresh ,but I received an
error so I ended up just doing an upgrade.

Clarification of Question by walsh153-ga on 23 Oct 2002 20:50 PDT
Also no changes where made.
Subject: Re: easy cd creator 5 is reading my cd-rom and my cd-rw as the same drive.
Answered By: pwizard-ga on 24 Oct 2002 06:45 PDT
Greetings suave153,

I going to help to solve your CDRW problem with Easy CD-Creator 5
Platinum, however it's going to involve a bit of troubleshooting.
We'll do this by utilizing the "ask for clarification" feature. I will
work with you on this until the problem is resolved (as long as there
is a resolution to be found and/or documented).

I think there are a couple of different things we should try first. My
initial feeling is that somewhere in the upgrade process, your two CD
drives somehow got switched around and it may have confused the
software (especially if it was installed before). What I would
recommend doing is switching the drives back to their original drive
letter configuration. This is done through the "Disk Management" piece
of "Computer Management" in Windows. Follow these steps:

Click on START --> Settings --> Control Panel. Go to Administrative
Tools --> Computer Management. On the left, click on Disk Management.
You will see your hard drives and cd drives both at the top and the
bottom of the right hand side. If you right-click on either of the CD
drives, you can select "Change Drive Letter and Path". Click on this
to change the drive letter to something further down the alphabet. You
can't select a drive letter currently in use by another drive. So, I
would change drive D: to F:, E: to D:, the F: to E:. This should get
you back to your original configuration that you mentioned above. Be
sure to reboot after the changes have been made.

After the reboot, verify through Windows Explorer that the drive
letters are representing the correct drives. Try running Easy
Cd-Creator again to see if the problem is solved. If the problem
persists, the next thing to try is download and upgrade your software
to the newest version. Roxio had quite a few problems with Easy CD 5
Platinum when it first came out, especially on the XP/2000 platform.
They have released several patches since then, so most likely it will
not hurt to have the patch loaded. You can download the newest update

Let's see if either of those solutions takes care of the problem. If
they don't, please ask for clarification and we'll continue our
troubleshooting process. Thanks!


Request for Answer Clarification by walsh153-ga on 24 Oct 2002 20:11 PDT
Dear PWizard,
I went in the control panel and into disk mgmt. and made the changes
you spoke
of with the drive letters.They appear to be right in explorer.
Now when I go to burn a cd the source drive=cd-rom=E comes up as D,the
destination drive=cdrw=D also comes up as D,so when I try to burn it
the computer says that the cd is closed.So somehow the same thing is
just with a different drive letter.
I went to that roxio link you sent me but when I went to download the
update I get a 404 error,time after time.So I uninstalled this program
called Take Two
that Roxio removes when you download the update(because of
problems)and tried again but still the same 404 error.

Clarification of Answer by pwizard-ga on 24 Oct 2002 20:43 PDT
It looks like either they made a programming mistake on their website
when they posted the latest update or possibly the file is just not
there yet. It looks like they JUST posted a new update today (they
show October 24 as the newest update). My guess is that the file
probably hasn't been made available on all of their ftp servers as of
yet. Please try the download again tomorrow as I'm sure they'll either
realize the mistake quickly (after 10,000 people email them about it)
or the file will replicate overnight. I'm still hoping that this
update will correct the problem you're having with the software. At
least now the drive letters are back how they should be.

Please let me know once you're able to download the update and see if
it fixes the problem. We'll continue from there.


Request for Answer Clarification by walsh153-ga on 24 Oct 2002 21:31 PDT
Hello PWizard,
I just wanted to say that the same problem happens when I try it using
musicmatch ,which will also burn cd's.

Clarification of Answer by pwizard-ga on 25 Oct 2002 05:14 PDT
One thing I didn't think about before (and probably should have) is
that your ASPI layer could probably use an update. This layer controls
CD writing in many CDR apps. You can download the update from here:

Install, reboot and see if this perhaps makes any difference. Another
thing you might try is downloading a completely different CDR app and
see if they too share the same problem. I would go with one of the
major ones like NERO ( or CDR-Win
( They both come in shareware versions that
you can try for free. This may help me determine if it's truly a
windows device-level problem or a application-level problem.


Request for Answer Clarification by walsh153-ga on 26 Oct 2002 17:54 PDT
Hello PWizard,
I installed the aspi update,rebooted and things were the same.I also
went to the Roxio site and installed the update,rebooted and things
are the same.
One thing I noticed though.while in the disk mgmt.area,when you open
the sub folders under each of the cd drives there is a drive
folder,when I select it
and click on properties it reads Drive 0,it does that for each of the
2 cd units.I just thought that was odd.

Clarification of Answer by pwizard-ga on 26 Oct 2002 18:59 PDT
OK, at least now we know for certain that the problem is with Windows
2000 and not with the recording software or ASPI layer. I do find it
very odd that both of your devices are showing as Drive 0. This is
almost definitely the cause of your problem. Windows believes that
both drives are a single device or are acting as some sort of media
pool. It's almost like it thinks you have a CD changer instead of two
different drives. If we can figure out how to make it see them as two
different device IDs, your problem would be solved. Can you tell me a
little bit about your hardware setup?

Motherboard type? VIA chipset?
How many hard drives? IDE or SCSI?
CD/CDRW drives IDE or SCSI?
How do you have the drives configured? Both CD drives on the same IDE
channel (if not SCSI)?

Keep taking a look around in Disk Management and in Device Manager
(same area). See if you see anything else that looks odd or any place
where it may indicate that the drives are setup in some sort of media
pool or setup as a virtual device. There may be a place where you can
change it if so. Look in Device Manager under CD/DVD Drives and make
sure it shows the correct name for both of your drives and has the
correct driver installed for each.

I will setup a Windows 2000 Pro machine over the next few days and see
if I can recreate the problem. I don't see anything under Windows XP
like you mentioned in your last statement "when you open the sub
folders under each of the cd drives there is a drive folder, when I
select it and click on properties it reads Drive 0". Can you tell me
exactly what steps you took to see that and what tab you clicked on?

We seem to be getting closer to an answer. I appreciate you working
with me on this to help solve the problem - I hope we can come up with
a resolution.


Request for Answer Clarification by walsh153-ga on 27 Oct 2002 00:15 PDT
Hello PWizard,
motherboard type-Intel SE440BX3 32 mb sd ram.My processor is a Dell
Pentium 3
500 mgz, 1 hard drive Maxtor 13 gig,Both cd's are set up on one IDE
ribbon,but they have always been that way since the start.My original
configuration when I bought the computer from Dell was that in drive D
where the cd-burner is now
was a zip drive.The physical Zip drive is still there of course under
the floppy drive but it is no longer drive D as it was before.Its no
longer plugged
into anything.
When I go into disk mgmt.below that is removable storagem,in a sub
folder is
physical locations,when you open up the sub folders there are my 2 cd
nec cd-rom  and lg-cdrw. If you open up the sub folders beneath each
cd unit you will see drives,if I select drives, in the right pane you
will see Name drive 0- nec cd-rom, the same for the other cd, Name
drive 0 -lg cdrw.I hope this helps.
                                       Thanks ,

Clarification of Answer by pwizard-ga on 29 Oct 2002 07:43 PST
I installed WIndows 2000 Pro and tried to recreate your problem, but
could not. I too have two CDrom drives on the same IDE channel and
nothing I did would result in them showing up with the same device id
number as yours do. I'm afraid there is not much else I can suggest
for you to do at this point. If it were my machine personally, I would
try things such as switching the cd devices so that they are split
between the two IDE channels and see if Windows straightens up and
sees them correctly at that point. If it does, you *might* be able to
switch them back successfully. I would probably also look for updated
versions of component level motherboard drivers for Windows 2000. You
could start with the Intel Chipset Software Installation Utility:

If there's a problem with your IDE and/or other device drivers, this
may correct the problem. I've searched through every resource I have
access to (Microsoft Technet, USENET, etc) and can not find any other
helpful articles or documentation that might help to solve your
problem. If these last suggestions don't work, it's my opinion that
you either take the PC into a professional computer shop so that
someone can look at the problem hands-on and do some real
troubleshooting or that you open a support call with Microsoft and let
one of their technicians try and assist you since they can talk with
the people that wrote the software and see what all scenarios might
could cause your particular problem. Then of course, there's always
the option of formatting the system and starting fresh.

I apologize that I wasn't able to come up with a clear-cut workable
solution to your problem. Please know that I tried very hard and put
in many hours of research trying to find the answer. If I happen to
come up with any other ideas, I will update this answer accordingly. I
do wish you the best of luck in trying to resolve your problem.


Request for Answer Clarification by walsh153-ga on 30 Oct 2002 19:26 PST
Hello PWizard.
Thank you for your help.
There are no comments at this time.

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy