Google Answers Logo
View Question
Q: Windows Does not Recognize Hard Drive (No Drive Letter) ( No Answer,   4 Comments )
Subject: Windows Does not Recognize Hard Drive (No Drive Letter)
Category: Computers > Hardware
Asked by: foofaraw-ga
List Price: $20.00
Posted: 30 May 2005 18:39 PDT
Expires: 10 Jun 2005 14:49 PDT
Question ID: 527492
I have two hard drives that I can't get Windows XP to recognize
anymore. Something (I think an uninstall of GoBack) wiped out the
drive letter information, and now the drives are not showing up in
Windows Explorer. I KNOW that the data is NOT destroyed - I did one of
those software data recovery previews ( and I can see
the entire directory tree.

To fix the problem, I tried going to Disk Management --> right-click
on the drive (it shows up as "New Volume" with no drive letter).
However, the option for "Change Drive Letter and Paths..." is grayed
out and I can't choose it.

So my question is: how do I get Windows and Windows Explorer to
recognize the data in this healthy and functioning NTFS partition?

Request for Question Clarification by tutuzdad-ga on 30 May 2005 18:54 PDT
Have you tried RIGHT CLICKING on MY COMPUTER icon on your desktop and
selecting MAP NETWORK DRIVE? (You'll get the same results by RIGHT
CLICKING on NETWORK NEIGHBORHOOD icon on your desktop and selecting

This is the method many people use to assign a drive name (i.e.,
letter) to a drive.

Let me know if this works.


Clarification of Question by foofaraw-ga on 30 May 2005 19:01 PDT
That does not seem to work. In the "Map Network Drive" dialog box,
there is a field called "Folder:". I tried clicking the "Browse..."
button next to that, but Windows can't find any drive to map.

Request for Question Clarification by tutuzdad-ga on 30 May 2005 19:48 PDT
Hang in there. This is really not my bag; I just happened upon it and
thought I'd make a suggestion. There are a number of researchers who
know much more about this. Hopefully one will happen along soon and
give you a hand.


Request for Question Clarification by livioflores-ga on 30 May 2005 20:11 PDT
Did you try unplugging the HD and then boot, then shut down and plug
the HD again to see if in the next boot is it recognized?

Clarification of Question by foofaraw-ga on 30 May 2005 20:18 PDT
Yes. The drive is in a removable drive bay. I have removed it,
rebooted the computer, and replaced the drive multiple times in an
attempt to fix this.

Clarification of Question by foofaraw-ga on 31 May 2005 06:26 PDT
Partition Magic: I tried that, but much like Disk Management,
Partition Magic could not identify the drive--I think it was showing
up as hexidecimal formatting.

Importing disk: Good suggestion. Using diskpart.exe, I selected the
disk, then tried to import it... unfortunately it says "The disk you
selected is not part of a group that may be imported."

GoBack: There do seem to be a lot of people out there that have had
similar problems related to GoBack. Unfortunately, not much in the way
of solutions.

MBRWORK: Sounds a bit risky... I don't know enough about disks to do
that with confidence.

So in Disk Management, the "Change Drive Letter" option is still
greyed out. It looks like I could select "Convert to Dynamic Disk..."
but I'm afraid to find out what will happen when I click that...

Request for Question Clarification by hummer-ga on 31 May 2005 07:30 PDT
Hi foofaraw,

Some more ideas, click on the link for more details:

1) Boot to the Recovery Console and then run this command
If you see it list the drive and its partitions then use the driver
lettes you see do this
chkdsk TheDriveLetter: /r
2) Check your jumpers carefully.  You may not have reset the old drive to slave.
3) Boot from an XP floppy, or use Command Console boot option to see
the "raw" drives unreassigned by XP.
4) DiskPart
5) Delete the paging file on your second hard drive. 
6) The solution is to simply put the hard drive back into the old
computer and uninstall GoBack. This is done in two steps. First you
need to hit the Space Bar while booting to access the GoBack menu.
From this menu you need to disable GoBack. Once GoBack is disabled you
need to load Windows and uninstall GoBack.

Good luck!

Clarification of Question by foofaraw-ga on 10 Jun 2005 14:48 PDT
I finally found an answer. I loaded a demo of PTDD Partition Table
Doctor ( and immediately got the error message:
"The partion type of Disk 3, Partition 1 is not Unknown. It is
HPFS/NTFS. Do you want to correct it?"

Answering "Yes" cost me $50, which is a pittance compared to what the
CRIMINALS at the "respectable" data recovery chop-shops wanted to
charge me. What an unbelievable racket!! Could I have fixed my drive
for free with a better knowledge of parition table writing, fdisk, or
whatever? Probably...

I am absolutely elated... but I am really hesitant to recommend PTDD,
for one reason: "someone" (gee, I wonder who) appears to have spammed
ads for PTDD all over Google Groups. Very bad form!

Thank you all very much for your suggestions!
There is no answer at this time.

Subject: Re: Windows Does not Recognize Hard Drive (No Drive Letter)
From: hobbes828-ga on 30 May 2005 23:50 PDT
Are these SATA hard drives, or even hard drives at all (or just
partitions), if so try plugging them into to different spots on the
motherboard.  Also, you may want to consider buying Partition Magic,
which should allow you to see the partitions, mess with them enough to
allow windows to recognize them again.
Subject: Re: Windows Does not Recognize Hard Drive (No Drive Letter)
From: raveen-ga on 30 May 2005 23:59 PDT
Do you have other Removable drives attached to the computer?
Do you have Mapped Drives on the computer?

I had that problem with a digital camera that connects to the computer
as a removable drive.

Most external drives will use the next sequential letter when loading,
if you have a mapped drive occuping the common letters (i.e. e: f: g:)
you might try the following.

1) go to Windows Explorer
2) Click on Tools: disconnect mapped drive
3) disconnect drives f, d, & e if connected.

Let me know if it works, or doesn't.
Id like to know.
Subject: Re: Windows Does not Recognize Hard Drive (No Drive Letter)
From: bumpher-ga on 31 May 2005 02:39 PDT
First of all stop pluggina and unplugging the hard drive, that is not
going to fix the problem. You say this problem occurred after you
performed and uninstall of microsoft goback? The mbr on that drive may
have been erased along with the partition table (this does not mean
that the data was erased).
If it was me I would be searching the documentation on goback and see
what I can find as far as issues with un-installation. ALSO, since you
know how to get into disk management, go back in there and see if you
have the option to import the disk. Lastly here is a program to try

 get MBRWORK from the free downloads at

Put it on a DOS bootable floppy, boot that and run MBRWORK

Use options
(so you can put things back with 2 and be no worse off)

3 then 4 to clear out the first track

There will then be A
To search the disk for signatures of partitions and build a new
Partition Table

and finally
5 to install standard MBR code

You may also need 6 to set  the partition with XP as active,
Subject: Re: Windows Does not Recognize Hard Drive (No Drive Letter)
From: myoarin-ga on 31 May 2005 03:54 PDT
If that doesn't work, there was a question some time back with all
sorts of suggestions:

Important Disclaimer: Answers and comments provided on Google Answers are general information, and are not intended to substitute for informed professional medical, psychiatric, psychological, tax, legal, investment, accounting, or other professional advice. Google does not endorse, and expressly disclaims liability for any product, manufacturer, distributor, service or service provider mentioned or any opinion expressed in answers or comments. Please read carefully the Google Answers Terms of Service.

If you feel that you have found inappropriate content, please let us know by emailing us at with the question ID listed above. Thank you.
Search Google Answers for
Google Answers  

Google Home - Answers FAQ - Terms of Service - Privacy Policy